Streaming clips is gone from the web client and standalone client

I can play the files just fine on the server, but not using the web client or the standalone client. This worked before I upgraded to 1.2.7 (running 1.1.6?, can’t remember).

What can I do to get this working again?

Can you see the files in the Libray in the windows client or are they gone?
0. Hsve you updated .Net framework to the latest 4.5.2?

  1. If you do not see the files in the Library NCS need to reindex all the files in the folder. Change library storage to an empty folder. Let ncs store some new files. Check that these files can be played in the windows and web client. Change storsge location back to the old folder. NCS will now start to reindex all files back to the Library.
  2. You might have to update VLC also to the latest version.
    Please, report back how it goes.

Hi henrik! :smile:
I apologize for the late reply.

Everything was fine, but I updated VLC nonetheless. Now it works in Edge and Internet Explorer, but sadly not in Firefox… :frowning:

Excellent! I am using Firefox, so can you be more precise what is not working.

Some browsers are blocking Flash since some time which can lead to playback not working anymore (Google Chromium not working anymore where Google Chrome Canary still works).

I suppose it can be for similar reasons in FF.

Flash is not blocked in FF.

Another thing is that when I doubleclick on a clip on the standalone Client, then Windows Media Player starts up instead of VLC. Is there a way to fix that?

Yes, that¨s the easy part ;). Right-click on the file you want to open and go to Open with and Choose another app. There you can pick the application you want. Don’t forget to check the box that save this choice for the future.

That’s on the server, but with the client (which I run on a couple of remote PCs), all I get when I right click is the option to “Remove” a clip. :wink:

This could be Windows 10 resetting some file associations, but which association is used for those clips?
(And if that was the case, I think Win10 would open the new Video app).

Aha, ok. First a stupid question, but … I assume you have VLC on the client machine. When I remove vlc on client another software starts. When back again vlc starts. I know that someone had a problem if VLC was installed in the Program or Program (x86).
Or try this, on the client machine go to the Control panel and to Default Programs. Go to Set Default programs. On the left hand side you should have VLC. Click on that and set it as Default program.
I hope this will do the job ;).