Super Bad FPS - But Xeoma works with the same setup

Hi, i have buyed two days ago NetCam Studio (16 cam) for 80€
now i i have 8 1080p cams @25 FPS witch i want to record / Motionrecord.

the live feed is super slow 3 - 7 FPS(App, Web, iOS APP) and the recordings are worse 0,5 - 2 FPS with frame drops

i Have a Trail from XEOMA witch works fine (around 23-25 FPS) by record and live (around 17-20 FPS)

My Hardware:
i5 3470s 4X 2,9Ghz
4GB Ram
SSD Harddrive (Windows)
1TB 7200 USB3.0 (Recordings)

NETGEAR GS116PP 16 Port Gigabit Ethernet

8X Evtevision POE IP Cam with ONVIV 1080p @ 25fps via rtsp

what is wrong with NetCamStudio?

Netcam Studio is free for 2 sources so you can download and test how it works. You can also add all the cameras with no problem to check all functions and performance. All this can be done before you purchase the software.
Netcam Studio and Xeoma are very different programs and also in quite different price range. If it works well in Xeoam continue with that software.
From your results it seems that the cpu has to much to do. Check the CPU load in the Task Manager. I assume it will be high.

is there no way or setting to get better results? i really like your software, but with this bad framerate its to bad for my home. :sleepy:

Probably it can get better, but, you must test and learn how your system works.
1.test to run only 4 cameras. What happens with fps and cpu load? you need 1080p? Is 720p ok on some cameras?
3.set cameras configuration to use variable bit rate. That will save calculations.
4.change from h.264 to MJPEG (no audio) compression in the cameras. Same resolution, but saves cpu power since mjpeg use less compression. More bandwidth on LAN, but that is not a problem. you really need 25fps from the cameras? recording, do you need 25fps. That use a lot of cpu. Usually 10 fps in enough. Also make sure that Preset is Ultrafast.
7.viewing of the cameras use also a lot of cpu power. In Client settings you can change how many fps the viewing should have…The figures you mentione above are these when viewing all cameras? It will be quite different when only viewing 1 cameras at a time. Client Settings disable high quality rendering. Netcam as a service and connect with web client will probably save some cpu load.
10.enable Multi-threading decoding/encoding in the Settings.

Some settings to experiment with. Do this for 3-4 cameras where you can see how the system reacts when changing parameters.


thank you, i will try, hope it helps, but again THANK YOU :blush:

1 Like

Hi, now i reduced the resulution of each camera (down to 720p - witch is nearly no different)

i disabled high quality rendering

now i have 20-25 fps :wink: by using arround 60-70% CPU
now im happy, thx for your help

1 Like