Support for INKERSCOOP IP66 720P HD Surveillance Camera

hi there,

I recently bought the above camera (INKERSCOOP IP66 720P HD Surveillance Camera and was wondering if anyone know if it can work with NCS? I know it has RTSP but have no idea how to configure NCS to work, I have tried various combinations but no luck.

Also tried VLC and cannot get any video out.

From what I can see, you need an ActiceX to stream the video to IE, but was wondering if anyone knows how to get it to work.

Thanks for the link. It helped. Usually, new cameras support the standard ONVIF which states how a camera communicate with a software like NCS. Unfortunately I do not see anything about onvif in the specifications However, in the Q&A there is question about connection to DVR and in the answer it says that the camera support ONVIF!
So, when you add the camera to NCS use the tab for Onvif Source and fill in parameters and finally select mode.
I hope this works and please report back how it goes.

Hi Henrik,

Thank you for the quick reply. Appreciated!

Some details on what I have:

I can access the cam admin page via Chrome on HTTP and under ‘Network’ there is a tab called ‘Onvif’

Two settings are both enabled; Onvif settings: [ENABLED/ON] and Onvif checking : [ENABLED/ON]

In NCS, I go to Edit the video source, ONVIF Source, browse and then it finds the cam (IP, MAC, Name). I select and click the check mark.

This then populates the first field calld ‘1. Select ONVIF Source’ with ‘’.

I then enter the admin username and password in the ‘2. Provide credentials’, and click ‘Get Profiles’.

I can see it does something (mouse cursor briefly goes to the Windows ring of patience), but in the third field called ‘3. Select Profile’ between ‘ONVIF Profile’ and ‘PTZ Mode’ the drop down list seems to be empty/grayed out. I click the tick in the bottom, and I get a red screen “Connection failed”

If I go into the Event logs, I get:

Exception (Web) while connecting to
Exception Detail:The remote server returned an error: (401) Unauthorized.

This is a bit more helpful, so I created a new user called ‘read’ as a ‘viewer’ and tested again, but still the same issue.

I have a bit of time on my hands tonight to do what you suggested ere: Connect custom IP camera video feed in Netcam Studio

I am pretty sure, as you said, it will be supported. Fingers crossed and I will report back!

The software that can show the video feed (on Windows 10 x64) is called iSmartViewPro

There is also a RSTP tab in the Network section in the admin page, wth the following settings:

Authentication = ON
RTSP port = 554

[I can only put two links in a post (new user!), so the links are edited - httpx should be http]

OK, I have found the following:

When you use IE to browse to the cam’s admin page on the LAN (httpx:// you are presented with two options after you log in:

View Video - Mode 1
View Video - Mode 2

This is what happens in Fiddler: When you hit ‘Mode 1’ (with Fiddler running) and you end up with a black screen saying ‘failed’

Fine, we can live with that!

Let’s look at the logs:

Fiddler log:

Result Protocol Host URL

1 304 HTTP /main.html?id=1&playtype=iv
2 304 HTTP /style/base.css
3 304 HTTP /style/main.css
4 200 HTTP /hy-cgi/user.cgi?cmd=checkuserinfo&ck_password=0
5 304 HTTP /js/public.js
6 304 HTTP /js/language.js
7 304 HTTP /images/logo.png
8 304 HTTP /images/index.png
9 304 HTTP /js/jquery.min.js
10 304 HTTP /language/english.js
11 304 HTTP /preview.html
12 304 HTTP /preview.html
13 304 HTTP /images/nav_bg.png
14 304 HTTP /images/user.gif
15 304 HTTP /images/menu_bg.png
16 304 HTTP /images/menu_bg_over.png
17 304 HTTP /style/preview.css
18 200 HTTP /hy-cgi/av.cgi?cmd=getvideoattr
19 200 HTTP /hy-cgi/device.cgi?cmd=getlandevices
20 200 HTTP /hy-cgi/ptz.cgi?cmd=preset&act=query
21 200 HTTP /hy-cgi/net.cgi?cmd=getrtspport&cmd=getrtspauth
22 200 HTTP /hy-cgi/user.cgi?cmd=checkuserinfo
23 304 HTTP /js/public.js
24 304 HTTP /js/language.js
25 304 HTTP /js/preview.js
26 304 HTTP /js/jquery.min.js
27 304 HTTP /images/stop.png
28 304 HTTP /images/audio.png
29 304 HTTP /images/mic.png
30 304 HTTP /images/snap.png
31 304 HTTP /images/record.png
32 304 HTTP /images/x1.png
33 304 HTTP /images/x1.gif
34 404 HTTP /images/alarmstatus.png
35 304 HTTP /images/ctrlpanel.png
36 304 HTTP /images/1_over.png
37 304 HTTP /images/2.png
38 304 HTTP /images/3.png
39 304 HTTP /images/x1_over.gif
40 304 HTTP /images/x4.gif
41 304 HTTP /images/up.png
42 304 HTTP /images/left.png
43 304 HTTP /images/center.png
44 304 HTTP /images/right.png
45 304 HTTP /images/down.png
46 304 HTTP /images/hscan.png
47 304 HTTP /images/vscan.png
48 304 HTTP /images/hvstop.png
49 304 HTTP /images/tour.png
50 304 HTTP /images/zoomin.png
51 304 HTTP /images/zoomout.png
52 304 HTTP /images/fout.png
53 304 HTTP /images/fin.png
54 304 HTTP /language/english.js
55 304 HTTP /images/1.png
56 304 HTTP /images/ctrlbg.png

When you use Mode 2, you can see video streaming using flash, Fiddler URL reporting something like this in the logs: httpx://

(I am NOT a big fan of flash, so moving on…)

From the above (Mode 1 Fiddler logs), I opened up (download and save the ‘preview.js’ file) from httpx:// with Atom and saw an entry in it for this:

rtsp://" + encodeURIComponent(username) + “:” + encodeURIComponent(password) + “@” + ip + "/live/ch0


Convert that to:


Pop that into NCS ‘Custom URL’ in the “Edit Video Source” and Voila!!!

Video streaming in glorious HD (just 720 since the cam only supports that!)

Thank you and hopefully this will help someone else who is trying to get a (very) cheap camera to work with NCS!

Now I have to decide to either buy a 4/16 source license or stick with the free 2 source since I already ordered another cam to replace this one, but I got it working!

Haha, excellent job my dear Watson! :slight_smile:

Problems is most likely that’. use port 80 and the web server need another port.
Something that works for ONVIF devices is to download ONVIF device manager. That software finds always the cams and reports the rtsp to pop into the tab for Custom URL.

Thanks again for a job well done and thanks for the feedback! Any more questions you know where to find me!

1 Like

No problems, just glad I could possibly help someone with the same issue in the future. Trying to PM you, but I cannot find a way, is it blocked on the forums/community?