The problem with the image

Good afternoon, was faced with the following problem. When testing your program in the trial version - everything is fine shows all the cameras connected correctly. But we had to enter the license key, restart the program and see the error image output from the cameras, the image flickers.

Tried on different operating systems: WindowsXP, Windows7, the result is the same.
The test PC has an Intel core i5-3470@3.20 GHz, RAM 4 GB, Hard disk 250 GB, integrated graphics card. Also has 2 AXIS camera M1114. With the network no problem, I want to clarify that the program worked correctly prior to entering the license key. Reinstallation of OS did not help.

Please help, don’t know what to do.

Hi Alex!
Thanks for info. Forwarded this to our developers @Steve
Which version of Webcam du you run?

Hi Henrik,
we installed it on a PC webcam7 PRO v Build 42150.

We getting error “[0] JPEG Decoder JPEG error #58 (BufferSize :: 1450135)” what does that mean?

Excellent info! That seems logic that the flicker has something to do with the decoder and buffersize, but exactly what I leave to the programmers. Do you have this?



I was traveling for the last 2 weeks and couldn’t check before.

What is strange is that you refer to webcam 7 but the screenshot is Netcam Studio. Are both software affected by the same problem? What is then the error reported on Netcam Studio side ?

This in webcamXP can occur if the image is bigger than the buffer size (so actually bigger than 1.45MB):
[0] JPEG Decoder JPEG error #58 (BufferSize :: 1450135)

What is the resolution of the source and the template / preset that you are using ?

Anyway apparently this is happening with mjpeg streams. I would need for this either a sample jpeg stream dump or access to camera. None of my mjpeg cameras seems to act this way…

Welcome back to the coalmine ;).
The 2 users reported in webcam7. The picture above is from NCS 137 and when I accessed mjpeg stream using http in Firefox. I have just installed 137 on my production server and do not see this problem. So it might have been on the i3 computer. If I see it again I come back.

which mjpeg stream have you been trying to access ?

jpeg shouldn’t be much sensible to performances (and uses very few resources)? it’s not like mpeg where you can miss packet and not decode some in mjpeg normally either you decode or not and it may get slower if overloaded…

then in webcamxp / webcam 7 it’s probably because it cannot really identify the end of one image and tries to decode more bytes than it should at once (or totally fills the buffer).

This is why it would be good to see if it’s only old foscam cameras users or more generic (i think one reported axis cameras, that seems really weird)… especially since mjpeg decoding in webcamxp / 7 didn’t change for really long (however i saw already this behaviour for the reason stated before).