TP-Link NC200, VLC = OK but not in Netcam Studio?

Recently I bought a TP Link NC200 IP camera, this one is not in the support list but I found the correct URL on the Internet. When I put this URL in VLC player it works like a charm, but then when I copy the URL to the Custom URL field in Netcam Studio v1.3.2.0 nothing happens and the screen stays black… Anyone that is using this camera or has/had the same issue?

The correct URL that i put into VLC is: http://admin:YWRtaW4=@MY_LAN_IP:8080/stream/getvideo

Hi! Yes, that camera seems to be a little bit tricky ;). Just the password was not the ordinary …
If it works in VLC it has a very strong chance to also work in NCS. Just some trivial things; when adding the cam as Custom URL you set the Stream Type to MJPEG. The default port is 80 so you have changed that to 8080 in the cam config. Yes, I know trivial … I ask because the discussions in the forums are a little bit strange I think. Have you also tested to use admin:admin or did you change that to the above?
I also found the URL http://admin:YWRtaW4=@my_lan_ip:8080/stream/video/mjpeg (That is maybe NC220?). Can you check that one.

Hi Henrik,

That URL you provide results in a 404 page. Why do I have to change the port, I got a working URL on port 8080, I didn’t change anything in the camera config so far. The URL works in VLC but not in Netcam Studio. Even in Google Chrome the URL give me the correct view.

Hi! Yes, I agree if it works in VLC. I ask because the discussion in the forums with this cam is strange. In the manual of the cam the pwd is admin and port is 80 as default, but as you say. OK, do this. Go to Settings -> Decoding/Encoding and change Decoding settings. Default should be Buffered, but change that to VLC or Unbuffered and see if that helps. Remember to restart after each change.

I changed to VLC and restarted the server, no result. Even changed it to Unbuffered but the same result, no view… Any thoughts? I can make this camera public so that you can test it if you want… Thanks!

Yes, do that and lets see if I can figure this out. You can send the info in a private message if you want. Click on my icon and you can see Message.

Hi, don’t see the option to send you a PM. Can I send you an e-mail?

OK, I just sent you a private message. You should see an icon in upper right corner. Return that with info.

Finally got it working thanks to Henrik!

The correct URL is: http://admin:YWRtaW4%3D@my_lan_ip:8080/snapshot.jpg

Stream type must be: JPEG

1 Like

FYI :smile:

1 Like

Nope, actually I got it from here:

Have you tried this:


I am not sure to understand, MJPEG works in VLC and in browser but not in Netcam Studio ?

It would be better to be able to use MJPEG (or RTSP) rather than JPEG.

It can be 2 things, either the MJPEG stream is really particular (wrong content-length or strange separator between images) or it may be related to authentication (Netcam Studio doesn’t or badly support Digest Authentication, I need to improve a few things here in upcoming versions).

I will be back mid-march if one of those camera is reachable I can have a closer look.

NC200 only deliver jpeg and mjpeg. Not rtsp. The URL works in browser, vlc and some other programs also. In NCS there will be this error message: Exception Detail:The server committed a protocol violation. Section=ResponseHeader Detail=‘Content-Length’ header value is invalid.

Yes, jpeg is slow with about 3 fps, but it works for the moment ;).

Do you have any idea of tp-link nc200 video content-type
I want to show video on my own android app
Thanks for your time

Hi Pravin!
To be honest this was a terrible camera to work with and it seems only designed to work with TP-links own systems. We got it finally to sort of work in NCS. I made a quick search and there are discussions about this. So I recommend you to do the same and see if you find useful information. Sorry, but I do not have that answer just up mu sleeve ;).
Good luck,

Tested in VLC stream video and
web browser
The password must be base64 encoded . In the examples here the standard password admin (YWRtaW4= in base64) is used.
Page to convert the password


I am new I am Latin and I translate in google apologize the misspellings