Unable to access/view cameras when using the Netcam Studio Service

We are currently using Netcam Studio for 3 network cameras. When using Netcam Studio Server X to run the software rather than the service, everything works fine.
If we use the Netcam Studio Service the client is unable to view any of our cameras, even from the machine that has Netcam installed using to connect. We get an error which says “Could not connect to Netcam Studio Server” even from the same server using We are using 2 Foscam 960p Cameras and a D-Link 720p Camera. We have another installation in another location which does not have this issue and from what we can see, its setup in the same way - the same OS (Windows 2012 R2 x64), same hardware etc. There only real difference is the Foscam cameras in the second location are a different model - the Dlink is the same model.

Currently, we have tried:

Disabling Windows firewall and also setting all zones to allow all traffic.
Reinstalling Netcam Studio on the same machine
Creating a brand new machine and setting up in the same way
Fully patching windows

Hi Joe!
Another mystery to be solved ;).
First, that was a new error message for me. An error message have usually more text so this is a little short. I am running the same server myself and I have tested several alternatives for this, but no. So I think we need to start from the beginning. Here are tests and questions. Maybe not all are relevant in your case, bur I need to know. You do not have do do this is my order ;). Maybe 7 is most likely.

Please point out when in the alternatives bellow the error message happens! I am not quite sure when the error occur.
0. when you start NCS X are there any error messages in the log?

  1. NCS X is running and you see all the cams. Motion detection or recording works fine?
    a. when you connect with the windows client it works?
    b. when you connect with the web client it works?
  2. stop NCS X completely.
  3. sttart NCS Service and make sure it is running.
    a. try to connect with the web client. Works?
    b. try to connect with the windows client. Works?
    c. try to connect using the LAN IP of the server. Works?
  4. Do you install NCS as an administrator?
  5. You write that "If we use the Netcam Studio Service the client is unable to view any of our cameras, even from the machine that has Netcam installed using to connect. We get an error which says “Could not connect to Netcam Studio Server” " Does this mean that you can start the windows client, but you do not see any cams. Or does it mean that you get the error when trying to start the client.
  6. When NCS X is running and you try to connect with the client are there any error messages in the Event Log?
  7. If it still is impossible to connect to the server from web or windows client using port 8100 I think that some other application is using port 8100 on that computer. Check if you have any other software running and blocking port 8100.

Just a final tips for server 2012. If you have many cams and the response is slow check that the power management is set to “High Performance”. When set to other options server 2012 have some strange things going on and slowing NCS down.


Hi Hendrik,

In answer to your questions:

0 - When we open up NCS X, there are no errors. In the logs (debug logs), everything is showing as green/OK.
1 - Motion detection and recording is working perfectly fine when NCS X is running.
a. If we connect using the windows client, we get the same error (the camera sources displays a message “Not connected to Netcam Studio Server”)
2 -
3 -
a. The web client works fine.
b. If we connect using the windows client, we get the same error (the camera sources displays a message “Not connected to Netcam Studio Server”)
c. using the LAN IP, localhost address or hostname the client doesn’t work.
4 - I have tried installing NCS logged on as local Administrator with the server not connected to the domain and also as a domain Administrator with the server connected to the domain and we get the same result.
5 - We are able to start and log into the Windows client but all of the sources have a white Netcam Studio page with the error message “Not connected to Netcam Studio Server”.
6 - Yes, there are quite a few. including the following:

High Performance mode was set before installation of NCS.

Thanks for coming back to me, hopefully we will be able to make some progress and get this fixed.


Further to the above information, I have checked the server has .NET 4.6.1 installed

I can also confirm that the iOS application works fine with NCS X or the Netcam Studio Service.

Hi Joe!
Thanks for all the info. Now I understand much better the problem and where the error message is!
I am happy that the web client works because then port 8100 is working.
All these white and gray camera images usually happens when URL, login or password is not correct.
This seems to an isolated problem with the windows client.
When you uninstalled NCS did up also remove the files in the folders Program Files - Netcam Studio and in ProgramData - Moonware ? If not, please unistall using the installer and then remove these files and folders. Install NCS again. Still same problem?


Hi Hendrik,

I went one step further and installed it on a brand new server (one that has never been used before and has been provisioned specifically for NCS X. Therefore the program Files were definitely free from NCS files) and we have the exact same issue. Surprisingly it worked initially and we could access the Cameras via the NCS Windows Client. I could be wrong but it seemed to stop working around the time we reset the Admin password for NCS. I tried changing it back to 1234 but it remains broken so not sure if this is just a coincidence.

Mysterious! You have one system that it works on and now 2 systems that it do not works on.
I have the same system as you have, server 2012R 64bit, and I have stresses NCS with everything I can think about, but never your problem shows up. Sorry for a stupid question, but is it a 32-bit version of NCS you are running?
Can I get access to the system using Teamviewer? If ok, I send you a PM where we can exchange secrets.

! You mentioned Foscam? These cameras sometimes works in mysterious ways … Is this only for Foscam or D-link also? Please, remove the Foscams and have only D-link connected. Same problem?

Most likely
Also, do you have the different NCS systems connected to the same cameras? So that one cameras delivers the SAME video stream to several NCS? That might also be a problem depending on the camera. Can the Foscams deliver 2 streams at the same time? Meaning connecting to the camera with two different URLs. These error messages may depend on that.



i had the same problem with an older version i believe it was ncs3.2 and i noticed that if you disabeld the network connection in windows and enabled it again ncs worked fully again witouth restarting the service…

Hi Hendrik,

Yes, you are fine to connect to the system. If you PM the details I’ll get you connected.

The installation is 64 bit.

We have this installation which has 2 foscam cameras and a dlink camera which has been problematic since day one, obviously as mentioned we have tried setting NCS up with the same cameras but on a brand new server and get the same issue.

We have another installation which has different cameras (other than the dlink camera) which also runs 2012 r2 and can run using the service without issue.

I have tried removing the 2 Foscam camera and this still doesn’t allow the dlink to work. I haven’t uninstalled NCS and set it up again with only the dlink so I will try that to see if it works.

Unfortunately, when running the service, disabling and enabling the NIC doesn’t rectify the issues but thanks for the suggestion.

Apologies, I may not have been entirely clear regarding the cameras, the dlink camera which is the same camera between the two installs is only the same model and not the same camera. (We have two of the same cameras in different locations connected to different installs) so to clarify the camera in this installation are unique to this install of NCS.

“We have another installation which has different cameras (other than the dlink camera) which also runs 2012 r2 and can run using the service without issue.” Can you forward these cameras to thr non-working sydtem and see if it works? That will be a good check.
Can you give me model numbers of the foscam and d-link cams for the non working system and the corresponding URL how yoy connect them.
PM on the way.

Hi! I think, I have the same problem.
Using WinServ2008 R2 x64. Using RTSP protocol for connect to my DVR with 12cams. Automatic starting NCS servise is work. But it doesn’t work, when I try to connect by webclient or open website with stream. CPU usage is 0-1%. When I stop service and run NCS server, all is ok and CPU usage is ~80%

First start NCS X and add all cameras so it works. Connect with the web client also and make sure everything is fine.
Exit NCS X. Then start NCS Service and then connect with the windows client. Can you see the cameras or not?

NCS use these 3 port to work correct:

These ports must be free and cannot be used for something else. Check that.


can I change standart ports like this?
add key=“WebServerPort” value=“82” /
add key=“ServerTcpPort” value=“8120” /
add key=“ServerHttpPort” value=“8124” /

Or service will be worked only with standart ports?

Yes, that is possible. But change in both config files. One for NCS service and one for NCS X. Make sure that port 82 is not used for something else in the computer. Use this port in the web and windows clients also.

When I start NCS client x64 with running NCS service, it doesn’t work. The same situation, when I try to connect with the web client. When I stop Service and run Server x64, all is ok.

I have to check using Teamvier what might be the problem. It is the same as earlier?

Sorry for delay. No. I changed ID. I send you PM with ID and password