Unable to add motion in scheduler

My goal is to create motion alert only for certain period of time during the day.

I have only server 1.5.4 ( did not want to install 1.5.5 yet )

With client 1.5.4, it crashed every time I tried to save after adding motion to scheduler.

With client 1.5.5, it ddoes not crash, but it does not save added motion in scheduler.



Tested here and seems to work normally with 1.5.5

Please note that we will not consider points like: did not want to install 1.5.5, we work and investigate on the most recent that we have made available here and that’s it, we’re not going to investigate on previous versions or mix of client and server versions.

Please also note that we have decided with Henrik that we are going to limit technical support for users which do not have a license to 20 or 30 minutes of our time per user maximum in a very close future. It’s not yet stated on the website or in the forum at this stage but it’s coming.

So first thing, update to 1.5.5, try on local machine first with netcam studio x, then with service + client and ensure you use an account with admin rights.

Thank you


I upgraded Server to 1.5.5.

I’m able to modify motion in scheduler with Netcam Studio X, but it’s not practical with my Service configuration.

I tested again with client and I could not modify neither motion nor record. The problem seems to be with local source only ( webcam )

I finally was able to add my external camera this evening and tested on it and it works.

So the problem is really in the situation where I use client to modify scheduler for local source camera.

Thank you for all your helps, i do appreciate it.

Ok, we’ll review with the mentioned configuration and try to reproduce.

Also tested and working as expected with local sources so the problem is somewhere else…

Here is what I observed

  1. From the Netcam Client, for the same 30 minutes ( 1 square ) , I can not add both Record and Motion
    However from Netcam studio X, I could do so ( have both Record and Motion for the same 30 minutes )

    And that what happened yesterday when I tried to add Motion to my local webcam scheduler that aleady had Record.
    I then tried to add Motion to my IP Cam (which had no Record ) and it worked
    That’s why I thought that the issue was on local web cam only.

  2. Once you use Netcam studio X to modify the scheduler of a particular camera, you can no longer use
    Netcam Client to modify that particular camera sheduler.
    The only way to fix it, is to remove that particular camera and re-add it.

On the 1 remark I agree.

It seems to keep the one you mark first. The second one i refused. It seems to be only with this combination of MD and R.

On the second one I cannot reproduce this whatever I do.

Actually the second point is as follow , when you use Netcam Studio X to add both Motion And Record tor any same 30 minutes ( same square ) then you can no longer use Netcam Client to modify scheduler for that particular camera.

If you want to use Netcam Client again to modify the scheduler for that particular camera, then you have to use Netcam Studio X to
remove any 30 minutes (square) with both Motion and Record

Sorry, that behavior I cannot reproduce eve if I do my best :slight_smile: . However, lets Steve have a look at the first one since it might have bearing on the second one also.

Probably the account that you use to run netcam service doesn’t have access right to edit / modify the configuration files in your hdd.

try to rename your folder: C:\ProgramData\Moonware\Netcam Studio to anything else

Start directly service and configure it from the client to see if it helps.

The windows account that I use to run netcam service does have right to modification files. I use the same windows account to login and run netcam as service for testing purposes

The problem occurs only where there is a combination of Motion and Record for the same 30 minutes for the same camera.

Here is my scenario test this morning

From Netcam Studio X add a camera
From Netcam client add the very same camera
From Netcam client add 1 motion to square Sunday at 0 hour, add 1 record to Sunday at 2:00 , save it
From Netcam Studio X add 1 motion to square Saturday at 0 hour, save it
From Netcam client add 1 record to Sunday 23, save it
From Netcam Studio X add 1 motion and 1 record to the same square Saturday 23, save it
From Netcam client remove motion from Sudany at 0 hour , save it, reopen and you’ll see it still there. From this point on you can
do any modificaiton you want from the client, it will never save.

From Netcam Studio X clear square Satury 23 which has both motion and record , save it

From Netcam Client, try any modifcation you want, save it , reopen the scheduler and you’ll see that the modiication is saved.

First question is why would one combine motion detection and recording ?

Motion is to send an alarm.
Record is to verify if the Motion is configured properly.

If this is by design then I’m ok with it, since I know the work around.


No it’s not by design, I was just wondering.

With your detailled steps I could reproduce a problem, looking in the client event logs would have directed me directly to the problem since it’s logging the exact error in the client logs.

I have updated the 1.5.5 package available here:

So that it should fix this problem. It’s now possible to combine recording and motion detection in the scheduler.
What I don’t get is by what magic it was working in Netcam Studio X since they both use the exact same code and logic but well now it should be a supported scenario.

It works now. Thank you very much.

Here is my feedback after one day test on this version

  • Even though it allows to have a combine of Motion and Record in the same 30 minutes in scheduler, only Record was triggered, Motion Detected was not
  • If only Motion Detected is scheduled or manually enable (without Record), netcam will start the record as usual but will not stop at Motion end, it will stop only at the end of the Record max time and start a new file, just like the Record was enable permanently

I see that there is version 1.5.6 in test, hopefully it will be fixed


Yes I have noticed strange behaviour of the scheduler when combining different type of actions and end of motion not being triggered anymore.

Normally 1.5.6 fixes that, I’m also testing it with couple of scenarios / combinations.