Unable to get streams

I just downloaded the Test Version of Webcam XP Pro, i can add a cam, the Testing to the Connection is ok, but i receive no Picture or i get a error the message is: an error occured while connecting to Video source 1, i tried with a panasonic Network cam, BL-230 and also 2 vivotek cams I receive the same Errors there as well…And the Test Connection is ok, and the panasonic don’t have username, the vivotek has usersnames and i entered of course the right Logins with Passwords…What is wrong? The cams are also in the same Network subnet…

Hi Roy! It is difficult to say from your text, but it seems to be a major error since none of the cams work. However, before we start I would like to ask if it is any special reason that you would like to use Webcam XP? If not I recommend to use NetCam Studio instead since it is the “next generation” and easier to work with.
Regards, Henrik

Hello Hendrik

I just got the hint to buy it from a friend, and he has no Trouble with the cams he uses different mades of cams as I do, but I have no idear why i am not able to have a stream from my cams…I the NetCam Studio easier to handle? My idea is it to Close all open Ports to my Webcams and only have 1 port open for the Webcam Server so ppl can go there to choose the cam…I tried on a Server 2012 with it, and to double check i installed the Webcam XP on my PC with Windows 8.1, same issues there…

Yes, it is much easier and I am using it ;). Your idea is of cause very good. I installed XP Pro on a server 2012 and installed a network camera (Dlink 942L). Click on Test gives OK. Click on OK and I get the video in the cam window. Is it here that it goes wrong? You get an OK on the test and when you click OK to continue you get the error message?

If you try to use RTSP templates, did you verify that you have Visual C++ 2013 Redistributable (32-bit) installed?


If you have purchased a webcamXP license and have more luck with Netcam Studio we can switch it for free in case.


Yes it’s installed but the Server is 2012 64 bit, is that might the Problem? Does Webcam XP run’s only on Windows 32 bit? As I mentioned i tried it on my PC with Windows 8.1 it’s also a 64bit Edition…

No it works fine and it’s widely used on 64-bit operating system as well (however webcamXP is a 32-bit app so it requires the 32-bit version of the dependency above).

Can you use those cameras in any other application ? What are the exact templates and presets that you are using ?

I used the bult in templates vor Vivotek Cams, and Pansonic, also treid with Axis 2100 Template which also not works, the Connection (HTTP) test is allway ok…I don’t know what is wrong…And a other question, when i bring it to work, is it possible to use the presets of a cam? As example I have about 6 Presets on a Panasnoc Pan/Tilt Cam…

OK, I might have found a problem. Add the Panasonic cam using Network Camera -> Connect. Use the Template for the Panasonic / BL-C230 / MJPEG 640x480 and click Next. Enter the IP number and nothing else! Click on Test and you will see that it is OK. You get an OK just to have the correct IP number. Then check the box that the camera is password protected and enter the correct user name and password. Then continue to click on OK at the bottom right corner.

The problem is that you get an OK from Test even if the user name and password is not correct. But to get the video stream user name and password must be correct. Check the camera that it have user name and password. You can use the web browser to connect to the camera to check that you have a valid user name and password. I can see from the specifications that the Panasonic cam also have https. Check that you use http.

Hello Hendrik

I just did as you mentioned, but still not able, still same error, really strange, the Panasonic doesn’t have a Password to connect to the Campage, I tried also with an Axis this cam has also no username and Password, but also not works…Same error message, if you like, have the time, I can open a remote connecttion for you to have a look…I am pretty sure this must work, because other have this in use without Trouble so mine should work too, but the Software Looks fine and nice, so that’s why I plan to choose it, but have to hurry up, before the Trial period is running out, and as soon it works I will purchase it or the netcam Studio…Whopps, forgott to mention, the cam’s are all using http not https…

Most cameras do require a password by default to access the streams, if really it’s currently unsecured, try to create an account and try to connect it with the username / password in the software.

Both Axis and Panasonic are very common (and very good brands btw), most of the models work the same way and use the same protocol so there is definitly something wrong.

Try to run webcamXP using the icon webcamXP (IP Camera mode) from the start menu, Maybe it’s the filter needed in the other / default mode that has not been installed properly.

Now I am really getting mad!!! ;). We all agree that something is very wrong ;). First test Admins suggestion. If that do not work open a remote connection and I see what I can do. Do you use TeamViewer? Send the info including username and password to a camera (s). Use the private message function. Click on my icon and you can see the message icon.

Hello Hendrik, this make me also very upset, so easy to use and a lot use it without a Problem… :frowning: But I can’t send you a private message, so try here on skype: uridium69, i will provide you the Details there

I just send you a private message. See if it turns up like a small icon in the upper right corner on the icon.

Problem solved. WebcamXP and Netcam Studio could not communicate with the cam using Jpeg. Maybe a cam problem? However, the cam could deliver an RTSP stream which was used with Netcam Studio and works fine.

Hello Hendrik… I tried my luck with Webcam XP on a normal Windows 7 PC, the message after choosing the made, type and resulation of the cam “an error occured while connecting to Video source 1” doesn’t appear here… I was able to get 3 cams of 7 live, but 4 have only a dark Screen and it say in the Screen “Connecting IP Caerma” but no stream nothing, the HTTP connecting is ok, and also the suername and Password… And 2 other important questions: 1. I have “Presets” on my PTZ Cams, how can I get the preset so a user can choose it? 2. Must the application be started all the time, when i Close it, or log off from the pc" the connecting to the 8080 Homepage is not available anymore…

Why go back to wxp? In wxp the Test only tests http (ip,port,user,password) and not if the cam delivers video and audio. In NCS the Test function includes http and video and audio. Why the screen is black I do not know. Install NCS and connect the camera and do the test and see if the icon for video and audio is green or red.
For your first question I do not quite understand what you mean so please explain a little bit more. For the second question. According to the FAQ wxp can run as a service. Go to Services and there you should find WebcamXP and start that. Check the documentation.

Hello…This was just a test only to see if there would be any difference…So the “good News” are that I am able to connect to 5 cams from total 7. The Software run’s on a virtual Windows 7 Professional Desktop with 4 GB Memory, i just don’t get my both Vivotek Cams running, the IP79 and IP51, the http Connection is ok with username and Password, but the Screen keeps black with connecting to cam …Does anybody have a idea how to fix it?`I tried with other similar Camera Modells in the list from vivotek without sucess…Wheni get this 2 to run, then i am totaly happy… About my first question in the last post, I have “Presets” on 3 Panasonic Cams, that means you press 1 and the cam moves to this Position, or 2 and goes to another Position which I I have defined before, so i can’t use this function when using Webcam 7…

I cannot find cameras named Vivotek IP79 or Vivotek IP51? Search on black screen in this forum and you will find others with same problems and some ideas for solution.