Unreleased listening TCP port 81x0 after uninstallation


Just tried to install 22 May 1.5.6, the installer told me it cannot install because there is already a version installed that I need to uninstall manually (was pre-22 may 1.5.6)

So I did uninstall and then reinstalled 22-may 1.5.6 but got error message telling tcp port 8120 was already used.

So I tried to undertsand and the strange thing is that in fact some no more existing process (I suppose it was NCS 1.5.6 pre-22 May) is still binded to those TCP ports.

I am using Win10 64bits and this is really amzing I never saw such situtaion, I tried to deactivate network card but still did not release the listening TCP ports.

I will reboot the PC that will fix the problem but just wanted to tell about this weird sitiuation.

Well process non-existent using a port is really weird. Never saw such neither…

After opening the Windows taskmanager, you can add the PID column to the displayed processes to see which executable at which location is the culprit.

I already now which process it is as it’s NCS TCP port and that is not really the question here and not sure TaskManager will show any information about no more existing process owned by the PID :wink:

I could reproduce the problem I think.

I tried to upgrade from 1.6.0 to 1.6.1 but as the installer is not able to fully stop and install correctly I decided to call the Tray Icon “Stop Netcam Studio Server” menu item then tried to click on “Exit”.

First of all this freeze Netcamstudio GUI, I suppose it’s normal as Netcam Studio Client lost connection to Netcam Studio Server but this should be managed isn’t it ? (I waited a few seconds to see if it went into some timeout managed situation but no).

As NCS client window was in frozen state any click inside made the “non reponding” Windows alert to popup, so I clicked “terminate” and here we are with non-exitent App still using 8120 TCP Port (and the RTSP TCP ports that were running), so I had to restart the computer to release it.