VLC doesn't start?


Environment :
Clean installation of VLC 2.2.0 32 bit and Netcam Studio 1.1.7 (32-bit) freshly installed.
(None of them was installed previously on this Windows 7 PC)
In Netcam Studio the Decoding settings -> VLC.
Video Source -> Custom URL -> RTSP_TCP : rtsp://admin:password@

There is no stream in Netcam Studio :
image link : "https://www.dropbox.com/s/gsapx275ptzfgjg/netcam.jpg?dl=0"
In the process list there is no VLC. Should it be there ?

The same stream run smoothly if I start it in external vlc.

Is there any idea what should I try ?

Thank You

In the log file I can see this :

(Warning @ 10:55:26.353 - H:749 - M:117,07MB) NetcamVideoSource(0) LibAV did not provide a frame after 15 seconds. Reinitializing connection (Retry 1)…
(Information @ 10:55:26.393 - H:710 - M:115,31MB) NetcamVideoSource(0) Quitting Worker Thread LibAV Video [requestedToStop]

VLC will never appear in the process list, we only use VLC’s libraries not the VLC app itself.

Give a try to the internal decoder in case it doesn’t work with the VLC decoding library.

Same black screen with the internal decoder also.
I choose the streaming format to H264_NOAUDIO in Netcam Studio decoding settings.
Is this correct ?

In VLC the stream is perfect.

This is the output format so it’s not related.

Does it take more than 15 seconds to start in VLC before displaying the stream ?

I measured, and yes it takes 17-18 seconds to start.

Ok, so this is probably the problem.

Netcam Studio has a timeout at 15 seconds and gives up if not video is received by them…

Try to see if by changing some video / quality settings directly in the camera may allow to reduce the initial connection time to something <= 10 sec

I’ve tried to reduce the quality. Reduced the bitrate from 8192 to 4096 and the quality to general from best.
llink : "https://www.dropbox.com/s/zsv8cj0cm57ou8y/CamQuality.jpg?dl=0"
link2 : “https://www.dropbox.com/s/ai0er2d17s9tqja/CamQuality2.jpg?dl=0

Nothing has changed, except the video quality is worse.
There is no posibility to increase the timeout variable parameter ?

At this time, the parameter cannot be changed and it not part of settings. I will look forward to increase this value in upcoming versions.

Do you have any estimated release date for the new version ?
Or may I get a beta version with the increased timeout ?

Please give a try to 1.1.8. I have posted links in this thread:

I’ve tried the 1.1.8 version. The result is same.
It seems that not the timeout the real problem.
I’m sure that 40 seconds should be enough, The stream start at around 16 seconds in VLC.

From the log file :
Information @ 09:06:15.233 - H:625 - M:86,85MB) ConsoleHost Moonware WCF Server Started…
(Information @ 09:06:15.241 - H:625 - M:87,94MB) ConsoleHost Listening @ net.tcp://localhost:8120/Moonware/ [netTcpEndpoint]
(Information @ 09:06:15.245 - H:625 - M:87,94MB) ConsoleHost Listening @ http://localhost:8124/Json [jsonEndpoint]
(Information @ 09:06:15.249 - H:625 - M:86,86MB) ConsoleHost Listening @ http://localhost:8124/Soap [soapEndpoint]
(Information @ 09:06:15.688 - H:685 - M:99,91MB) UserManager New User connected: Admin from [1]
(Information @ 09:06:32.399 - H:704 - M:108,29MB) NetcamVideoSource(0) Quitting Worker Thread LibAV Video [requestedToStop]
(Warning @ 09:07:02.473 - H:760 - M:173,16MB) NetcamVideoSource(0) LibAV did not provide a frame after 40 seconds. Reinitializing connection (Retry 1)…

Try as well with the internal decoder using RTSP_TCP or RTSP_UDP, here I see that VLC anyway sent a stop flag after 15 seconds based on timestamps so maybe there is a place where I forgot to modify this time.

Now with internal decoder and rtsp_tcp I can see the stream in Netcam Studio, but it not continous, sometimes stops, after that it speed up.
In VLC the same stream is continous on the same PC, so its not related to network.
The CPU load under 20% at peak.

I can see this lines many time in the log file :

(Information @ 12:21:40.040 - H:691 - M:103,34MB) NetcamVideoSource(0) Stream Event received [DeviceLost]
(Warning @ 12:21:40.087 - H:688 - M:100,60MB) NetcamVideoSource(0) Connection with rtsp://user:password@ has been lost. Will try to reconnect in 500ms…
(Information @ 12:21:56.248 - H:692 - M:106,08MB) NetcamVideoSource(0) Stream Event received [DeviceLost]
(Warning @ 12:21:56.342 - H:689 - M:102,30MB) NetcamVideoSource(0) Connection with rtsp://user:password@ has been lost. Will try to reconnect in 500ms…
(Information @ 12:22:12.581 - H:684 - M:101,53MB) NetcamVideoSource(0) Stream Event received [DeviceLost]
(Warning @ 12:22:12.613 - H:681 - M:102,54MB) NetcamVideoSource(0) Connection with rtsp://user:password@ has been lost. Will try to reconnect in 500ms…
(Information @ 12:22:28.759 - H:681 - M:104,39MB) NetcamVideoSource(0) Stream Event received [DeviceLost]
(Warning @ 12:22:28.774 - H:678 - M:106,45MB) NetcamVideoSource(0) Connection with rtsp://user:password@ has been lost. Will try to reconnect in 500ms…

Do you have any advice to avoid these disconnections ?
Have you found a solution for VLC decoding ?
I would like to use Netcam studio.

The issues reported are quite specific to your hardware and since we don’t have the same hardware here to perform tests it’s a bit delicate to make modifications without being able to test.

We continue improving the way decoding works for both modes based on what we can test physically and the hardware that we have available. You may just have to wait a few more versions.

I have reviewed VLC library code and the timeout increase was apparently implemented correctly and behaves as it should. Now I don’t have right now the answer on why it still refuses to connect on your end even with the increased timeout.

What is the exact reference of your camera ? If it starts becoming popular and several customers make the request then we may look forward to purchase one.

My camera is a ZModo ZH-IXA15-WAC

I made a short video maybe it can help to determine the problem :


In the video you, if you checking the second part of the time on the upper right corners, you can see that the stream is running continously
in VLC and stop and start in Netcamstudio with internal decoder. They are running parallel on the same pc, and displaying the same stream.

Even in VLC I can see decoding errors, artefacts and hops.

This is not a really good sign since in most case VLC manages to bypass and fix those. Either you are lucky and this is matter of setting the camera correctly by modifying the video settings or you’re not and it really provides bad quality streams full of errors and you may not be able to do much about it until they release a fixed firmware.