Wanscam JW0010-Z?

Can you add a driver for the Wanscam JW0010-Z?

I configured for the JW0004 but the PTZ controls do not work correctly (probably does not work on the JW0004 either). Any time I try to pan, it goes in to into an auto scan mode and will not stop.

The zoom function does not work either.

To do so I need to know what the PTZ commands are. Can you assist with that, please. This a rather old camera. Have you tested for some other PTZ camera to make it work?

I have used other software and am able to pan.

This is currently sold and I don’t consider it old. I have purchased a few
more and waiting on them to arrive.

IP Cam Viewer uses a generic driver and it pans ok (IPCAM1 , (IPCAM2).

Not sure how to get you the commands.

David Caffey

I also used a Wanscam driver for JW0008 and JW0004 and both worked in the
IPCAM Viewer.

David Caffey

There are several models of the Wanscam with PTZ. The basic commands are all the same, but the the data string is a little bit different between them. Can you check if one works better than the other.
Also, the button can work a little bit different depending on camera. Either press the button and release when correct position or click when to start and click when to stop.

I got the PTZ commands for the Wanscam and we have the correct ones in our files. Foscam use the same set of commands so test also with Foscam.


AJ-COWA-B1D8-1 , AJ-C2WA-C118, and AJ-C2WA-C198 pan buttons work correctly but neither of the zoom buttons work.

Also, a left/right auto pan begins if you click in the picture frame and will only stop if you click left, right, up, or down.

Excellent. All the cameras you tested use the same command strings. Now I have the correct PT commands. Video works fine also?

Zoom is also in the template so why that do not work is strange. They are also the same as Wanscams command list.
You can test this. Since it is html commands you can use a browser to send ptz commands. Have the camera running in NCS and open a web browser and send this string to the camera:

http://username:password@cameraIP:port/decoder_control.cgi?command=16 That should zoom in

http://username:password@cameraIP:port/decoder_control.cgi?command=18 That should zoom out

port is usually 80, but if you have changed that use your port number.


Video works fine.
Browser truncates the username:password@ data and tries to access the cameras GUI. Any special way I should send the command? I tried Microsoft Edge and Google Chrome.

Hm, I use that URL when testing in Chrome.

Use this one first http://cameraIP:port and login to the camera so that logins is saved and then the url below in another tab


Not sure what I’m doing wrong. I’ve tried it in Chrome, Microsoft edge (both in windows 10).

That is wrong

It should be

Opps, my mistake, typo.
Still not working. Could send you the IP:port in a private message so you can test remotely?

Use conand=6 or command=4 which is left and right so we know it works.
I send you a PM about details.