Webcam goes offline

I use a Logitech C525 webcam and everything appears to work for a few hours until the camera goes offline. I can only reactivate it again by stopping and restarting Netcam Studio. I have looked at error and critical sections of the logs and there is nothing in there.

I know others have had similar issues and it was suggested to try WebcamXP. However, WebcamXP is not an option for me because the email sending does not work (on everything I tried including my own email server) and I receive a Socket #10054 error when testing email in WebcamXP and besides, the download section of WebcamXP strongly suggests using Netcam Studio!

I have tried many settings in NCS and regularly experience the issue of the webcam going offline. I tried to start the service in Windows Service Manager but it does not start (although I can start and stop NCS from the tray icon). What is the point of the Netcam Service if it never starts?

Hi there,
That was a lot of problems :slight_smile: The C525 is usually not an issue … Netcam Studio Service is default set to Manual. So the first time you need to start it manually. You se change manual to automatic and it will start by itself. Are you using version 1.5.6?

Thanks for the speedy reply. My problem is that the service cannot be started from Windows Service Manager, yet it is possible to start it from the tray icon context menu (and stop it from tray icon). Once I start it from tray icon, the Logitech C525 camera works for a few hours and goes offline. Restarting from the tray icon context menu brings it back online again.

My gripe about the Windows Service Manager is that it seems to be inconsistent with starting and stopping from tray icon. Why is it that I cannot start the service in Windows Service Manager, yet I can start and stop NCS from the tray icon context menu.

So, there are 2 issues. The one that is a showstopper is the Logitech C525 webcam going offline after a few hours and the other issue, which is of lesser importance, is that I cannot start the Windows service (but can start NCS from tray icon’s context menu).

Yes, I am using Netcam Studio 1.5.6

Ah, I solved the problem of running it as a service from Windows Service Manager. I cannot have Netcam Studio Server GUI at the same time.

However, there is still the problem when I have the Netcam Studio Server GUI running (but the Windows Service is stopped) I get the disconnection of the webcam after a few hours.

First, for NCS; NCS X (Server) and NCS running as a Service cannot run at the same time since they use the same resources. Therefore, you have the NCS Client that can connect to both server and service respectively when they are running.

I am not quite sure of when the webcam stops running. Is it:
1.NCS running as a service ?
2.NCS X running with open GUI ?
3.NCS X running with closed GUI ?

When you say disconnect, what exactly do you mean. When you are using motion detection or continuously recording on the webcam it just stops after a few hours?

If you use WebcamXP does it work there apart from the email problem?

I am getting suspicious if the usb hub goes to sleep for some reason. In the driver of the usb hub you can quite often select if it should go to sleep or not to save energy.

Is this running on a desktop computer or a laptop?


Hi Henrik,

NCS X is running as closed GUI and the service has NOT been started. I am able to use all the functionality of NCS but after a period of time (maybe about 10 hours), the camera appears offline. By that,. I mean motion detection does not work and when I attempt to view the camera from the NCS client, I am not seeing a live stream but I see a picture that was taken many hours ago. The picture does not change and the timestamp with the frame rate on the bottom right of the image does not change.

Due to these issues, I installed WebcamXP and upon finding out there were issues with email, I uninstalled it immediately so I did not try my webcam with WebcamXP.

The NCS X Server is running on a desktop designed to be online 24/7, so most power saving features have been turned off but I have not turned off the power saving of the USB hubs. However, I have noticed that if I close down the NCS GUI and start the service from Windows Service Manager, I have had the webcam operating correctly! This is a good enough solution for me but it would be useful to find out why it does not work correctly if Windows Service is not started and NCS X is running with the closed GUI.

The situation you describe in the first paragraph with a frozen picture can happen when the power to the camera is lost and when the power returns the data communications don´t start again or a faulty camera. However, this is always shown in the event listing and the logs as a lost communication with the camera. But, you don´t see anything in the logs? If you run NCS as a service and have the NCS Client open do the same situation occur with a frozen picture?

OK thanks, I will do some tests when I have some time. I didn’t see anything in the logs but maybe I was looking at the wrong place because I had filtered the logs by error and critical. Perhaps the relevant log messages were not error or critical logs.

They are under Debug, Information or Warning. Use Information and you will have it all. They have orange icons.

Have been doing quite some tests with usb cameras recently and in NCS it seems to handle them pretty well, even if they go to sleep and wake-up on demand (as they should) and I have been doing so during days and days.

Anyway from your description the first thing I see that you have to get rid of is the USB hubs.

10 years ago people using usb cameras already had issues with webcamXP (often frozen image / dying driver because it looses connection to the camera) so the golden rule is:

  • no extender
  • no usb hub
  • connect usb cameras directly to usb ports on the mainboard (no extra pci card with more ports)
  • no arguments like i cannot because cameras are too far away (in this case it’s time to switch to network cameras)

At least to make a test, please try the above, i’m 90% sure it will solve your problems.

I ask the rhetorical question “why does this issue not occur with Yawcam?” Of course, NCS is by far, a superior product to Yawcam and therefore, I will persevere with NCS.

Network cameras are out of the question as far as I am concerned because the video is streamed via external servers (based on what I have seen from other network camera users). I would love to use the pan, tilt, zoom features of network cameras but they don’t require static IP addresses, which arouses my suspicions of the video stream being routed via external servers (of which many are based in China). I will try your suggestion of connecting my USB camera directly to a USB socket on the motherboard.

yawcam still uses totally outdated video for windows technology and therefore uses less usb bandwidth and it’s less subject to such problems as it’s pulling frame by frame.

i’m not saying that ncs is better just that there’s nothing wrong with it and it’s probably on your end that something is wrong.

OK, thanks for the info. I wasn’t expecting an explanation as to why using Yawcam doesn’t result in the webcam sleeping issues but your explanation is a bonus.

As I said, NCS is by far a superior product to Yawcam and I will test it with the USB camera connected directly to the motherboard USB socket. However, as I reported earlier, I ran NCS successfully for seversl days as a Windows service. It is only in GUI mode, that I experienced the USB camera going offline.

Just luck in my opinion. Then it really depends on how sensitive the webcam driver is.

Some don’t care and recover automatically quite well and some other do not recover. Again i’m not 100% sure it’s this but it quite looks like…

I just have the same issue with frozen frame from a webcam. I suggest that if developers know about this issue, it would be good to make some workaround and re-connect to the camera automatically if there is a frozen frame. It should be a standard option. I know it may be the webcam driver to blame, but if the driver cannot be fixed fo obvious reasons, the best solution is to make a workaround,

I forward this to see what we can do to make it better.