Webclient login not working


I am trying out Netcam Studio now and I do like it better than WebcamXP, especially the motion detection settings and feedback. However, one problem I am experiencing is the ability to login to the webclient and be able to monitor and control the server. For my test, I have the Netcam Studio X running. I can see in the status bar "Online @ I am using my browser on the same local machine.

I have tried accessing:

In all scenarios, I do get the Netcam Studio web interface login on the browser. However, all attempts to login fail with a dialog that states “Invalid username or password.” I have tried the default “admin” user with 1234, as well as a couple other usernames I created.

I am running Netcam Studio X (x64) v1.2.7.0 on Windows 7 64-bit Professional. The browser I am using to access the web client is the latest Chrome.

Any assistance? I need this to work before I can consider switching over.

Thank You

Hi Troy. I made an installation with the same system as yours. With no camera added to NCS i could not login from the browser (Firefox) at all, not to NCS X or NCS running as a Service. I added a camera using the windows client (NCS X) and then I could login to both X and service version from the web browser. Can that be the problem?

I have 4 IP cameras added. They are all working as expected as well. Motion detection is working as expected on them as well. I added them through the NCS X. I am not running the NCS service right now, just the NCS X server, as I experiment and test suitability/stability. So, wouldn’t seem that is the problem.

BTW…I have since tried IE as the browser for access to the web client. Same problem.

One other tidbit of info, that could be affecting this. I have the free version installed right now, as I am testing its suitability. The free version is supposed to be limited to 2 cameras, but I have 4 cameras added. The resulting effect is that the last 2 added cameras have that banner across them that states “Evaluation Purposes Only”. I didn’t care about that banner right now, since I am indeed evaluating it. Could that be limiting the web client access functionality in anyway? I could always remove two of the cameras and test, but that sort of puts an artificial limit on my evaluation. I am hoping someone from Moonware can advise.

Thank You

Sorry! However, 4 cams is not the problem.

Some other tidbits of info…I tried the Android app for access to the server. When I attempt to login, it also reports “Invalid username or password”. I have set the password on the accounts I am using multiple times. The password is a mixture of upper case, lower case, numbers and a pound sign.

Hmm…Wondering now if the pound sign is causing a problem with the way this was coded. Depending on how something is coded, a pound sign could be a special character that causes problems.

Well hell…That was the problem. The pound sign in the password for the user accounts was causing the problem.

Moonware developers: You should code that differently. The pound sign should not cause problems. You should be able to handle all special characters in the password.


Can you please check / confirm the problem of have # in password ?

Yes, # causes problems. The cause is on both sides - bug in web client and issue with .net/wcf which doesn’t url decode hash sign %23, as well as few other special symbols.
UPDATE: I couldn’t find good way to fix this. I can’t use dirty hacks like replace “%23” to “#” or “%25” to “%” - this sequence can be used in password. The only way which worked fine is to use POST instead of GET. I’m afraid it will affect mobile client. @Admin, what do you think?

1 Like