Activation on Virtual machine. Linux host - solved


Hi, I have recently moved my netcamstudio from dedicated PC to diferent hardware runnig Xen project hypervisor running a cople of virtual machines on top of it. One VM is window7 guest onto which I have installed Netcamstudio. I asked for my licence to be released for activaton on the new machine. After trying to activate license (16 sources) I get message invalid HW id so I copied HW ID and asked for offline activation key. After this arrived I tried ofline activation but no luck ncs again said invalid HW key.

Is there a special procedure to get NCS activated on OS running as VM guest?



Hi Petr,
No, there is no special procedure for activate NCS on a VM. I do that myself. It seems that it is not released yet. Please, contact support agsin since I cannot assist you from here. If further problems, please come back here. Sorry for this.

unlisted #3


Hi Henrik,
Thanks for quick reply. I have contacted licensing and asked them to double-check my license release for reactivation. I will see whether it helps in a couple of days.



Hi Henrik, I have tried again after license reactivation but no luck.
I looked at log an found this message:

WCF request failed >> GetLicenseStatus()
Exception Detail:The request channel timed out while waiting for a reply after 00:01:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.

After failed registration attempt the license on the server is locket again and subsequent attempts just return invalid license key.



Ok. I am back in my office within 4 hours and I will deal with this ASAP.
Sorry for this,



there should be no issue running and activating NCS in VM however then you cannot change the VM config (memory, nb of cores, etc…) otherwise it will be detected as hardware change.

Please extract the logs from the event viewer in ncs after a failed activation, it may provide more information about what went wrong.


and of course you also cannot move the virtual machine to another computer or it will again be detected as a hardware change…


Hi Steve,

I have noticed that HW ID is changing with amout of RAM configured for the VM. I settled for configuration of VCPUs and RAM that seems to be sufficient to run the netcamstudio with a current configuration.
When I had the licence released for activation and run the online activation the netcamstudio slowed to a croll and then froze completelly so I had to shut it down in task manager. But it seems locked the license on lic server, because subsequent attempt return invalid license key in a few seconds.
I have tried to activate the licence with server.config and security copied from old machine. Could it be a problem? Should i have activate it before copying the settings?

Where are the log files stored? I seem to have a touble locating them.



Hi Petr,
You cannot move and use anything from other computers! This will not work. I suggest the following. Set up NCS on a VM machine with RAM, cores, HDD etc so NCS works as you want. These settings cannot be changed after the license procedure. Ask support to release the license again and wait for the answer. Start NCS X and enter the Licence key and activate.
The VM cannot be moved to another computer since that is detected as change of hardware. If anything is changed you must release the license again.
Before you start the licensing process enable the logging function like this.

  • go to C:\Program Files\Netcam Studio - 64-bit
  • open

-change false to true here and save

The logfile is located here: C:\ProgramData\Moonware\Netcam Studio\Server
The ProgramData is usually a hidden folder so you need to make that visible in the Control panel first to see it.

To be really safe uninstall NCS and remove all config files in the library’s shown above. Then install NCS again to have a clean installation.



Hi Henrik,
I have now fresh install after unistalling and removing all (progr files NCS -x64; Progr data Moonware; Appdata **) and I have enabled logging.
just waiting for the licence to be released.



Hi all,
I have an update. I have VM set up and configured without any changes needed now. I have tried activate the licese after release for activation. I get " invalid license" straight away. As I am a fan of moonware, I persuaded our acountant to buy additional license to try out activation. After entering a new license code - same result - "Invalid license ".


Hi Petr,
Thanks for all your work! Then we need to figure out the problem. If I understand correct NCS have been running correct on a dedicated computer. So I need information to reproduce it on my side. For example I run HP-server - ESXi - Server 2008 - NCS. And that woks fine.
What is your configuration so I hopefully can reproduce it on my side? For test I have Intel i3 and i7 with Win 10.


Hi Henrik,
I run Xen project hypervisor 4.8 on Debian 9 Stretch on top of it Windows 7 Pro and at the moment one Debian 9 VM besides of W7 VM. Netcam Studio . The HW is almost the same as the one which had run same version of netcamstudio before just with bigger hdd.



Hehe, that is something i cannot reproduce on my side ;). The strange part is that when you enter a new license code it says “Invalid license”. A new license code should not give that response. Can you give me access with TeamViewer to see if I can figure out what is going on. If OK, I send you a PM for exchange of info.


o.k. its up SID: 836 059 525 PWD:7176


Somehow it seems that it cannot active on-line and then it says invalid license. I suggest the following:

  • ask support to release the licenses again,
  • enter a license code and click on on-line activation. Now you will probably get the possibility to activate off-line. Click on that one and you will get the license code and a hardware ID. Send that to support and they will enter that in the database.
  • after “some time” that should work.



Hi Henrik,
I have tried offline activation before. I did get offline activation key for the same HW ID you have seen. It did not work either same response “Invalid license”.




Hm, what did the loggfile say about this? Loggfile is in ProgramData - Moonware folder. Is it a problem for the system to get in contact with the license server?