Camera from China X8900-MH36

I also have an outdoor wifi chinese cam, actually I have 4 of it: X8900-MH36. On iPad( with 360eye app) they are working. At windows 10 they are working with MVCS_lite software. They are using MMCC (multimedia conference control tool) and port 5050. How to get these cams working with NCS i.e. VLC. I tried all the rtsp-options mentioned in this thread.

Hi Ni,

If it is this camera is says in the pictures with the camera it support onvif standard. So when adding the camera to NCS use the tab for ONVIF source.

When you use MVCS_lite how do you connect to the camera?
According to the specs it do not support rtsp, but use a P2P protocol. So it is just to test.


Thx for responding! Yes thats the cam. I tried onvif source but in the device browser it did not find any device in my ip range.
In mvcs_lite I connected by adding manual a cam with the following data:

device name: name of the cam given by me
device id: local cam ip
net port: 5050
user: loginname
pw: password
device type; ipcam
chn count: 1

BTW (just in case needed), these are the open ports of the cam:

23/tcp open telnet
554/tcp open rtsp
5050/tcp open mmcc
5051/tcp open ida-agent
8800/tcp open sunwebadmin
8899/tcp open ospf-lite

Oops forgot to mention, before opening mvcs_lite I had (once) to click at VideoCodec.exe

Port 554 is open so it support rtsp.
It might support onvif, but not on any standard port. Download onvif device manager and see if that opens the cam. There you get the rtsp url.
Or it can be easy like add cam with tab custom url. Set stream type to rtsp_tcp. Address is rtsp://username:passworf@cameraIP:554/

My last option is to run Wireshark and analyse the data traffic when using mvcs_lite.

Thx again. Damm onvif dm did not find it and with wireshark I see for both cams port 5050 and 5051. And at port 5050 there is so less data.
I tried cutom url but unfortunately. Must be a fancy url or so they use…
Maybe an idea if you want have time to login in here with teamviewer

Yes. I can do TV, but first use filter in WS and put rtsp there if it finds that in any stream.

I did alreay rtsp filter but no results

Where can I find MVCS_lite? OK, I found it with another name. However, I cannot connect. X-server running?

X-server? Not that I know. Did you first start VideoCodec.exe? You have to run that first (one time) than start MVCS_Lite.
There might be another possibility: deassembling the mvcs_lite files…

Henrik logged from remote to my system and tried to find the URL for this cam but he could not find it. Than he did some work at his own computer and relogged in from remote to my system in the hope to find something with Wireshark. What we saw was an encryption in stead of an URL, which probably pointed to some chinese characters. Finally he could not do anything more for me. I thanked him for the lot of time he spend to help me, which is very very appreciable!

Than I contacted the vendor in China and find out that the developper of the iOS/Android APP “360eye” is the boss of that vendor, his name Guotai Liu (Liu is his first name). They asked engineers and they said: we are sorry we could not help you. This cam is only to be used with APPS or with NVCMS_LITE at a PC.

I found an url for downloading the .apk file, looked into it (i.e. deassembling) and finally with ONVIF I found the url of the cams:

rtsp://LAN IP/live/ch00_1

so strange, but without a login and password and with double slashes in the URL.
When your Dargo cam X8900-MH36 has f.i the url than you can watch it by using


Of course you can also use the login and password:


Again and again: Henrik thank you so very very much !!!

Thank you also for an excellent detective work :smile: I am happy we finally made it since it seems to be a good camera.

A post was split to a new topic: Guudgo GD-SC03 camera


I have this cam also, but can’t get it to work on my home router wifi network.
Followed all the instructions and made sure passwords are correct and so on.

This is what I did.
First reset to factory (button on cam)
Login to the cam MD…wifi. Check. Works.
The cam shows up in the device list of the app.
I have a nice streaming video on my phone.

Now I want it to connect to my home WiFi.
So: Setting - Network
App tells me it is in “AP” mode.
Now I check the Station mode and chose my router and fill in the right password.
That should be enough.
Cam reboots…i think. The green LED on the power-cord goes off and after a minute is start flashing shortly and than it is on.
I login to my home WiFi
But the cam is offline. Adding the cam again doesn’t work, scanning my network does not show any new IP address at all.
After a while (a few minutes) the MD…Wifi router is reappearing again. I can login to that and everything is fine, but only in AP mode!

So the cam is not saving the new settings! I can change passwords, but not the AP or Station Mode!

What am I missing here?

Any thoughts?

Is it a problem with Netcam Studio and this camera?

No, Just getting it to logon to my home network.

Hey guys. @Henrik maybe you will be able to help :smiley:
I just bought one of these Chinese cameras with belief that it will come with some stream URL. Unfortunately it didn’t.

Works flawlessly with 360Eyes app for Android, but not so well on PC app. I can rotate the camera, but I don’t see the picture. Both can be downloaded from

I also tried url what @ni_hao wrote before, but without success. Maybe they have updated the app.

Can you give me any tips how to connect to this camera? Any software to use as well.

Camera model: PW2L2A06A-GTY
In wifi settings it is named - IPC365
I also inspected code of android app and found username is - admin. Password can be changed in the app, but currently it is empty


Sorry, but no. According to specs it do not support onvif or rtsp so professional software like Netcam Studio have problems with that.

FYI: In my last post above (click here), I wrote that the url for the X8900-MH36 IP camera is:

rtsp://LAN IP/live/ch00_1

However, that is the URL for getting HD video. There is also another url for SD Video:

rtsp://LAN IP/live/ch00_0

1 Like


I have the same camera. Which program are you using? I’m trying to stream the camera with IP Cam viewer, vlc, onvif camera monitor, but it wont connect.

Thx grtz ralph