Fentac V380 Connection

hi all

many thanks to @sk8darr and @smashin for providing the fix i needed for my camera. i can now telnet into the cam and (almost) use rtsp.

unfortunately rtsp only provides a snapshot and i have been unable to get a video feed going.

any help would be much appreciated.

1 Like

Further to my previous message the url i am using is:

it looks like the gremlins have left, so this morning i was able to stream using rtsp.

once again, my thanks to @sk8darr and @smashin for making it possible.


1 Like

I’ve managed to integrate the following camera with home assistant using rtsp.

camera: https://www.banggood.com/Xiaovv-Q8-HD-1080P-360-Panoramic-IP-Camera-Onvif-Support-Infrared-Night-Vision-AI-Mo-tion-Detection-Machine-Panoramic-Camera-from-xiaomi-youpin-p-1491062.html?rmmds=myorder

but i have no success configure onvif with home assistant.

someone manged to do so ?

1 Like

Same goes for me. I need RTSP to work for this exact camera.

Any luck upgrading yet?

System app version: AppV380E21_PTZ_ETH_V3.2.1.3_20190102
System kernel version: KerV380E21_PTZ_ETH_V3.1.0_20181220
System firmware version: HwV380E21_WF3_PTZ_ETH_20160217

Has anyone been able to enable RTSP on E21? I’ve seen a firmware upgrade in this thread for E11 and E3
I bought an outdoor camera VR-380-Q10 C. I can access the video stream from an Android app. But I need to be able to access it via ONVIF/RTSP stream. It looks like it is somehow disabled as no ports are open on the camera’s IP after a full port scan. Does anyone know how to enable RTSP/ONVIF.
Firmware version

1 Like

I also have the 21 version and I wrote to their customer service. They answered and they sent me a file. With this RSTP is working. Here are their instructions:

step 1: copy the “ceshi” file and paste it to SD card root directory(means if there are any folders in the card, do not put it in any of them)
step 2: insert the card into camera again and restart the camera, wait for the camera proceed automatically, it may speak some Chinese
step 3: delete the file i sent you in the SD card and restart the camera

I don’t know how to upload a file here, better if you create one, because it is easy.

File name: ceshi.ini



This did not work for me. The camera does say something in Chinese during boot twice. Bu still do not see any open ports for rtsp after reboot. What rtsp stream are you using now when it is working for you?

I have the same camera as @Yoni. Try to unplug an plug in again. If you have the same Xiaovv camera it should work. I already have the second one. It is working in VLC and Home Assistant as well.

This is what I use:

I used my V380 for a while then I had some connection problem, then I’ve just did a hard reset (3 seconds on reset button)
Now I can hear camera boot and says “APN established” but I can’t see on WIFI so I can’t connect to setup.
I’m blocked.
I downloaded V300_V380E3_C_V3.2.1.0.zip (given above) updated the firmware but still no APN service to connect and configure.
Any help / advice?

1 Like

I am using CCTV camera based on v380 and using windows app downloaded from www.av380.cn

This app is working fine and I can login on my laptop when it use my home internet but when i use same login details on my office’s PC then it shows network connection error because we have firewall in our office.

So which port should be opened in our office to proper use of v380 windows based app.

My 2nd issue is that when we give nick name to any camera in v380 app with a account and we use same account details with another device then we can find connected camera but nick name not.

May be this app is storing nick name locally in device.

Please help that v380 pc app could work after open ports and nick name should remain same with same login details in another device.

Just in case someone also has the IP Camera, Wifi Camera Mini Camera with Infrared Night Vision 2 Way Audio Motion Tracker CCTV P2P Home Security (Bracket Type) from “ShenziTech”:

  • System kernel version: KerV380E12_PCARD_V50_V2.2.0_20160506
  • System firmware version: HwV380E12_WF3_PCARD_V50_20160217

By default this version has only port 8800 open. I followed the instructions by @grunwald and afterwards have ports 554, 8800 and 8899 open. Here is exactly what I did and what happened:

  1. Power the camera on
  2. Remove SD card
  3. Put the ceshi.ini file on the card (mine had unix line endings and no blank line after the two lines, but I am pretty both of this does not matter)
  4. Put the SD card into the camera
  5. Switch the camera off and on again
  6. The camera says:
    • System starting
    • chinese
    • System startup completed
    • establishing access point
    • access point established
    • chinese (same as before if I am not mistaken)
  7. The access point is then not established and I needed to power the cam off an on again.

The following address then works with vlc player:


Thanks again @grunwald

p.s.: The login via a github account seems to be broken. I was getting the Redirect URI mismatch error all the time.

I’m having no end of troubles trying to access my camera external to my home network. I’ve downloaded NCS and ONVIF Device Manager, but have had absolutely no luck watching any streams at all from my camera. both NCS and ODM find the camera just fine, but each attempt to watch anything results in “No Signal” for ODS and using NCS always results in “Connection failed”. Using their apps, MVCMS Lite on PC and V380 Pro on Android, I can watch it anytime I want, provided I’m on my home WiFi.

My camera details are as follows:
Firmware version: V380E12_WF3_PTZ_20160217
Software version: V380E12_PTZ_V2.5.6.4_20181126

I’ve seen the messages about upgrades, but the links don’t appear to work any longer, or maybe I’m just impatient. Either way, is there a good link to get the upgrade files from that I’ve read about?

I’ve tried forwarding ports 554 and 5050, 8800 and 8899, but again, no luck.

I’ve tried emailing (twice) v380technical@gmail.com and haven’t heard anything back at all.

As far as I understand, only the “official” tools are working, even from the home wifi? Here is a short list for diagnosis and hopefully solution:

Step 1: Determine open ports

Use a port scanner (e.g. nmap under Linux) to scan the cam for open ports. If you find only port 8800 open, this would explain why only v380 and MVCMS are working.

Step 2: Try to open more ports

The links from sk8darr and smashin are working, I used both yesterday. But with the V380E12, I would first try ceshi.ini file to open rtsp and onvif as described by grunwald and me.
If this does not work (= Step 3 fails), you can also try the upgrades.

Step 3: Verify additional open ports

Run the port scan again. Hopefully port 554 and 8899 are open now. Verify with e.g. vlc player. The exact URL can probably be guessed from the left panel in MVCMS.

Step 4: External access

First off: Have some security and privacy concerns. There are multiple options:

The “official” way

Create a cloud account with the V380 app. If the camera is connected to your home wifi and has internet access, everything should magically work: You can now look at the cam with the app from everywhere.

Behind the scenes, the data stream from your camera is passed to a public cloud server. V380 logs into this server and you can retrieve the stream to your phone. We do not know how well the cloud server is secured, whether the streams are encrypted at all etc. In principal it is possible to encrypt the stream end to end, but whether this is done, we do not know.

Port forwarding

If port 554 on the camera is open and you know its ip in your home network, you can configure a decent router to expose this port to the public. From outside, you must then connect to the public ip of your home network. A dynamic DNS service is helpful here.

For this to be reasonably secure, the user name and password for the cam should be long and strong AND rtsp authentication should happen encrypted (I have not checked with my camera, but now I will…) .


This is probably an easy and secure way.

SSH port forwarding/tunneling

In combination with a dynamic dns service, this would be my goto, but it requires an ssh server in your home network. The concept is explained e.g. here.

Have luck!

1 Like

Start MVCMS Lite and do the search for devices. When the camera is found check the port in the list. Most likely it is 5050 which is a very special multimedia port with an encrypted stream. You can see the video in MVCMS Lite and in the App since they use port 5050. ODM and NCS do nut use these ports. NCS use port 554 with the correct URL and ODM can use port 80 or 8080 if the camera is enabled for that.

Yes, you are correct, both official tools work within my home’s WiFi, but not externally. I have the same security concerns as well and was considering setting up a personal VPN at my home to connect to it. I do have a V380 cloud account set up, but I only get a black screen with the spinning circle.

I’ve tried using telnet, and ssh, to get to the camera, but each connection is refused. I’ll try those links again, I was probably just being impatient.

I was going to scan it for open ports last night, but ran out of time, I’ll try that tonight when I get home.

I downloaded the update files and the first time I tried using them I got an “Upgrade failed” message. I then tried reformatting my MicroSD and copying the files again, but could never get it to give that message, or any other for that matter, after inserting the MicroSD other than the typical “System is starting”, etc.

I’m hoping that if I’m able to access the filesystem I can determine/fix the issue. I’ve tried telnet and ssh to get to the camera, but each connection is refused.

Hi sk8darr,

  1. THANK YOU very much the Upgrade file worked like a charm.
  2. Please can you help me get the full firmware for v380 ip cam my 2nd cam keeps rebooting. can’t reset it… Thanks!!!

Got a new SD card, other one was obviously bad, and now I’m updated and can view the stream in NCS or OVM, or VLC but still within my home network. Looking into a VPN solution as I prefer security over convenience.

Thanks for your help! :smiley:

It turns out the issue is my phone, I’m able to get to the camera from any other device without issue, so no VPN, port forwarding, etc. necessary. I already had a cloud account, but it simply didn’t work on my phone. Will try blowing away all the app data and logging in fresh on my phone to see if that will resolve the problem, but either way, I’m very satisfied due to your help.