Fentac V380 Connection

Hi @sk8darr I bought a camera which I have set up with the V380S app. It only has ports 5050,5051,8800 and 8899 enabled. ONVIF Device Manager can detect it but not start a stream because there’s no RTSP port.

I tried the update files linked earlier in this discussion but it did not help.

The app says the current software on the device is

System app: AppGMS_CARD_V3.5.0.5_20170629
Kernel: KerGMS_V1.7.2.0_20170524
Firmware: HwGMS_WF3_CARD_20160217

Any suggestions on how I could adapt your patch to work on this camera?


I wrote to v380technical@gmail.com who immediately send me back a patch that worked for my camera. Now enjoying RTSP!

1 Like

Obviously they have discovered that upgrade to rtsp is good for marketing and increase sales :smile:

1 Like

Did you find a solution?
As I have bought a camera with the same version and the patch doesn’t work for me as well.


I think I sent an email to support but never got a reply.
Maybe a second try will be more successful.


I got a reply just after 10 seconds and after sending a screencapture of firmware versions I received upgrade files that you put on a SD card in the camera. He wrote that different versions needed different upgrades, we know that from earlier experiances, so ask for support for V300-V380 based cameras at v380technical@gmail.com

My version where originally:


and upgrade changed that to:




1 Like

Thank you all.

I just bought a V380 camera and was able to open ports 23 and 554 for RTSP with the update shared here.

Camera details:
Software Version: AppV380E11_IP38_ETH_V2.5.0.9_20171120
Kernel Version: KerV380E11_IPC38_ETH_V2.1.0_20160506
Hardware Version: HwV380E11_WF1_IPC38_ETH_20160217

I Used the version shared by @ smashin

hi all

many thanks to @sk8darr and @smashin for providing the fix i needed for my camera. i can now telnet into the cam and (almost) use rtsp.

unfortunately rtsp only provides a snapshot and i have been unable to get a video feed going.

any help would be much appreciated.

1 Like

Further to my previous message the url i am using is:

it looks like the gremlins have left, so this morning i was able to stream using rtsp.

once again, my thanks to @sk8darr and @smashin for making it possible.


1 Like

I’ve managed to integrate the following camera with home assistant using rtsp.

camera: https://www.banggood.com/Xiaovv-Q8-HD-1080P-360-Panoramic-IP-Camera-Onvif-Support-Infrared-Night-Vision-AI-Mo-tion-Detection-Machine-Panoramic-Camera-from-xiaomi-youpin-p-1491062.html?rmmds=myorder

but i have no success configure onvif with home assistant.

someone manged to do so ?

1 Like

Same goes for me. I need RTSP to work for this exact camera.

Any luck upgrading yet?

System app version: AppV380E21_PTZ_ETH_V3.2.1.3_20190102
System kernel version: KerV380E21_PTZ_ETH_V3.1.0_20181220
System firmware version: HwV380E21_WF3_PTZ_ETH_20160217

Has anyone been able to enable RTSP on E21? I’ve seen a firmware upgrade in this thread for E11 and E3
I bought an outdoor camera VR-380-Q10 C. I can access the video stream from an Android app. But I need to be able to access it via ONVIF/RTSP stream. It looks like it is somehow disabled as no ports are open on the camera’s IP after a full port scan. Does anyone know how to enable RTSP/ONVIF.
Firmware version

1 Like

I also have the 21 version and I wrote to their customer service. They answered and they sent me a file. With this RSTP is working. Here are their instructions:

step 1: copy the “ceshi” file and paste it to SD card root directory(means if there are any folders in the card, do not put it in any of them)
step 2: insert the card into camera again and restart the camera, wait for the camera proceed automatically, it may speak some Chinese
step 3: delete the file i sent you in the SD card and restart the camera

I don’t know how to upload a file here, better if you create one, because it is easy.

File name: ceshi.ini



This did not work for me. The camera does say something in Chinese during boot twice. Bu still do not see any open ports for rtsp after reboot. What rtsp stream are you using now when it is working for you?

I have the same camera as @Yoni. Try to unplug an plug in again. If you have the same Xiaovv camera it should work. I already have the second one. It is working in VLC and Home Assistant as well.

This is what I use:

I used my V380 for a while then I had some connection problem, then I’ve just did a hard reset (3 seconds on reset button)
Now I can hear camera boot and says “APN established” but I can’t see on WIFI so I can’t connect to setup.
I’m blocked.
I downloaded V300_V380E3_C_V3.2.1.0.zip (given above) updated the firmware but still no APN service to connect and configure.
Any help / advice?

1 Like

I am using CCTV camera based on v380 and using windows app downloaded from www.av380.cn

This app is working fine and I can login on my laptop when it use my home internet but when i use same login details on my office’s PC then it shows network connection error because we have firewall in our office.

So which port should be opened in our office to proper use of v380 windows based app.

My 2nd issue is that when we give nick name to any camera in v380 app with a account and we use same account details with another device then we can find connected camera but nick name not.

May be this app is storing nick name locally in device.

Please help that v380 pc app could work after open ports and nick name should remain same with same login details in another device.

Just in case someone also has the IP Camera, Wifi Camera Mini Camera with Infrared Night Vision 2 Way Audio Motion Tracker CCTV P2P Home Security (Bracket Type) from “ShenziTech”:

  • System kernel version: KerV380E12_PCARD_V50_V2.2.0_20160506
  • System firmware version: HwV380E12_WF3_PCARD_V50_20160217

By default this version has only port 8800 open. I followed the instructions by @grunwald and afterwards have ports 554, 8800 and 8899 open. Here is exactly what I did and what happened:

  1. Power the camera on
  2. Remove SD card
  3. Put the ceshi.ini file on the card (mine had unix line endings and no blank line after the two lines, but I am pretty both of this does not matter)
  4. Put the SD card into the camera
  5. Switch the camera off and on again
  6. The camera says:
    • System starting
    • chinese
    • System startup completed
    • establishing access point
    • access point established
    • chinese (same as before if I am not mistaken)
  7. The access point is then not established and I needed to power the cam off an on again.

The following address then works with vlc player:


Thanks again @grunwald

p.s.: The login via a github account seems to be broken. I was getting the Redirect URI mismatch error all the time.

I’m having no end of troubles trying to access my camera external to my home network. I’ve downloaded NCS and ONVIF Device Manager, but have had absolutely no luck watching any streams at all from my camera. both NCS and ODM find the camera just fine, but each attempt to watch anything results in “No Signal” for ODS and using NCS always results in “Connection failed”. Using their apps, MVCMS Lite on PC and V380 Pro on Android, I can watch it anytime I want, provided I’m on my home WiFi.

My camera details are as follows:
Firmware version: V380E12_WF3_PTZ_20160217
Software version: V380E12_PTZ_V2.5.6.4_20181126

I’ve seen the messages about upgrades, but the links don’t appear to work any longer, or maybe I’m just impatient. Either way, is there a good link to get the upgrade files from that I’ve read about?

I’ve tried forwarding ports 554 and 5050, 8800 and 8899, but again, no luck.

I’ve tried emailing (twice) v380technical@gmail.com and haven’t heard anything back at all.