Fentac V380 Connection

As far as I understand, only the “official” tools are working, even from the home wifi? Here is a short list for diagnosis and hopefully solution:

Step 1: Determine open ports

Use a port scanner (e.g. nmap under Linux) to scan the cam for open ports. If you find only port 8800 open, this would explain why only v380 and MVCMS are working.

Step 2: Try to open more ports

The links from sk8darr and smashin are working, I used both yesterday. But with the V380E12, I would first try ceshi.ini file to open rtsp and onvif as described by grunwald and me.
If this does not work (= Step 3 fails), you can also try the upgrades.

Step 3: Verify additional open ports

Run the port scan again. Hopefully port 554 and 8899 are open now. Verify with e.g. vlc player. The exact URL can probably be guessed from the left panel in MVCMS.

Step 4: External access

First off: Have some security and privacy concerns. There are multiple options:

The “official” way

Create a cloud account with the V380 app. If the camera is connected to your home wifi and has internet access, everything should magically work: You can now look at the cam with the app from everywhere.

Behind the scenes, the data stream from your camera is passed to a public cloud server. V380 logs into this server and you can retrieve the stream to your phone. We do not know how well the cloud server is secured, whether the streams are encrypted at all etc. In principal it is possible to encrypt the stream end to end, but whether this is done, we do not know.

Port forwarding

If port 554 on the camera is open and you know its ip in your home network, you can configure a decent router to expose this port to the public. From outside, you must then connect to the public ip of your home network. A dynamic DNS service is helpful here.

For this to be reasonably secure, the user name and password for the cam should be long and strong AND rtsp authentication should happen encrypted (I have not checked with my camera, but now I will…) .

VPN

This is probably an easy and secure way.

SSH port forwarding/tunneling

In combination with a dynamic dns service, this would be my goto, but it requires an ssh server in your home network. The concept is explained e.g. here.

Have luck!

1 Like

Start MVCMS Lite and do the search for devices. When the camera is found check the port in the list. Most likely it is 5050 which is a very special multimedia port with an encrypted stream. You can see the video in MVCMS Lite and in the App since they use port 5050. ODM and NCS do nut use these ports. NCS use port 554 with the correct URL and ODM can use port 80 or 8080 if the camera is enabled for that.

Yes, you are correct, both official tools work within my home’s WiFi, but not externally. I have the same security concerns as well and was considering setting up a personal VPN at my home to connect to it. I do have a V380 cloud account set up, but I only get a black screen with the spinning circle.

I’ve tried using telnet, and ssh, to get to the camera, but each connection is refused. I’ll try those links again, I was probably just being impatient.

I was going to scan it for open ports last night, but ran out of time, I’ll try that tonight when I get home.

I downloaded the update files and the first time I tried using them I got an “Upgrade failed” message. I then tried reformatting my MicroSD and copying the files again, but could never get it to give that message, or any other for that matter, after inserting the MicroSD other than the typical “System is starting”, etc.

I’m hoping that if I’m able to access the filesystem I can determine/fix the issue. I’ve tried telnet and ssh to get to the camera, but each connection is refused.

Hi sk8darr,

  1. THANK YOU very much the Upgrade file worked like a charm.
  2. Please can you help me get the full firmware for v380 ip cam my 2nd cam keeps rebooting. can’t reset it… Thanks!!!

@linusp
Got a new SD card, other one was obviously bad, and now I’m updated and can view the stream in NCS or OVM, or VLC but still within my home network. Looking into a VPN solution as I prefer security over convenience.

Thanks for your help! :smiley:

@linusp
It turns out the issue is my phone, I’m able to get to the camera from any other device without issue, so no VPN, port forwarding, etc. necessary. I already had a cloud account, but it simply didn’t work on my phone. Will try blowing away all the app data and logging in fresh on my phone to see if that will resolve the problem, but either way, I’m very satisfied due to your help.

Hi Domnic,

You’re welcome

Sure, I will try to help you in what I can.
Did you try to remove the sd card from de camera and test if with that the camera boot normally?

Hi Everyone,

This forum has helped me get a better understanding of the V380s
I have a couple of camera having the following details

System app version:
AppV380E23_PTZ ETH V 302020180620

System kernel version:
KerV380E23_PTZ_ETH_V 21020160506

System firmware version:
HWV380E23_WF1_PTZ ETH 20160217

I was and still having trouble getting the RTSP stream for the camera (I will try the ceshi.ini method)
Although I saw many of your guys indicated that the device has telnet support but were not able to get in, I was able to get into the using telnet by simply using the username root and no password

image

I was able to l locate the config file at “/mnt/mtd/mvconf/factory_const.ini” where I did add the rtsp line but that doesn’t seem to be still working even after the reboot.

Anyways, I’ll probably figure out a way now, but I wanted to share the telnet update in the meanwhile.

Hey, @Yoni how did you get this camera working with Home Assistant? Could you share your configuration.yaml?

Mine is as follow:

camera:
  - platform: generic
    still_image_url: ?????
    stream_source: rtsp://192.168.0.XXX:554/live/ch00_1
    name: Camera
    username: XXXXX
    password: XXXX 

What did you put in your still_image? I managed to get the camera working with rtsp using VLC Media. But no luck getting it to work with Home Assistant.

And did you manage to get it working with ONVIF as well?

Thanks.

@brunozumba
Hi, did you manage?

Is there a way to control the camera from Home Assistant also for other commands (PAN, audio, others)?

@klagio
Not yet =/

Still trying

ok, I got RTSP working with ceshi.ini , but now RTSP stream is available with any password. Can you please confirm that you see this too?

Great thread!
I followed the instructions to open rtsp on a v380 Panoramic (light bulb) cam.
Did anybody manage to find a solution for start/stopping the LEDs remotely (besides using the iOS/Android apps)?
If I manage to do this this camera is a keeper.

Hi,
I have the same camera with rtsp working but with the same concerns:

  • No password to access to the streaming.
  • How can I be sure the camera is not accessible from the outside or is sending anything to the outside?

I blocked the device in the router, so it should no be able, but…I want to be 100% sure

Sorry, there is nothing like 100% in this business :slight_smile:
You can install Wireshark. There you can monitor the traffic from/to the camera.
If you really are that concerned maybe you should buy a camera that you do not need to crack to get to work and that also use a password of your choice.
-Henrik

Hi all IP-cam maniacs :wink:

I try update V380 but I find this very difficult.

Stream from rtsp is ON but only by LAN not by Wifi - dont know why!

I paid for V380 9,99 GBP few weeks ago. Seller send me money back when I write to him that there is no rtsp and all stream can be played only inside V380 app on mobile or PC.

If someone like to take this “IP Camera” from me - fell free - I live near by London.

Basicly I use two ESCAM G02 and one Easy N F3 series - work perfectly fine!

Stream can be opened everywhere - on xbox and PC - under Kodi & Surveillance Room
from maikito26!

Also on mobile apps on phone and tablets.

All ports can be forwarded outside LAN without any problems.

V380 is total s**t with full respect to sellers from Ebay and all other shops.

Only one solution what I can see now is idea about…

“how change firmware V380 for any other”. I try with ESCAM G02 - none of this work so far.

Maybe you had some Idea how turn some useless piece of plastic with V380 software & firmware in to worked IP Camera ?

Hi all!
Thank you so much for your contributions. I managed to see the video through the “/live/ch00_1” url. I tried contacting support but never replied.

Ports 8899, 554 and 8800 are open but, there’s no audio!.. I’ve tried everything, any clue about how to get the audio too?

Also, port 23 is closed (@smashin firmware didn’t work) … do you know how to open it for telnet and maybe get more info?

Any help is much appreciated.

Thanks!

Try this in ceshi.ini
[CONST_PARAM]
rtsp=1
rtspaudio=1
audio=1
audiorec=1
audiorecord=1
micrec=1
mic=1
micrecord=1
telnet=1
ssh=1
onvif=1
web=1
webinterface=1
webif=1
http=1

Thank you very much Vasilii for your reply. That was a good try… but still no good luck: No audio and no telnet access. Only ports open after full scan are 554, 8800 and 8899… There must be a different set of commands for ceshi.ini maybe… ?

The support team told me there is no audio in rtsp… Did anyone manage to actually have it?
Also told me they do not provide telnet access!.. too bad.