How to Auto start Studio from computer reboot Windows10

How to Auto start Studio from computer reboot Windows10.

During night time W10 does its upgrades etc and any reboots, but Studio does not restart automatically.

How can I achieve this, as I would have thought it was requirement or at least a setup option.

You run Netcam Studio as a Service and set it up to start Automatically Delayed with Windows.
A search in this forum giives also info.
There is a guide describing this.

I Tried that and it does not work for me.

Tried to Run service manually.

Comes back with error - Windows could not start Netcam Studio Server 64bit service on local computer.

Check back in Services menu, and it says that the service is running ??

Try to run Studio X console and it comes back with error message - cannot run Console and Service at the same time.

I think I might not be doing something right, but not sure?

Stop Netcam Studio. Go to Task Manager and make sure NCS is not running; NCS X or Service. If it is just click on End task.
Follow the guide Using Netcam Studio Service
Still not working?
Did you install NCS under an account with Admin rights?
Is the Library on the local computer or on a network storage like a NAS?

Hi - Managed to get NetcamStudio.Client.exe to autostart.

But it has an input screen for the username and password. It then hangs there all night, missing a possible crutial video, until somebody enters the data first thing in the morning.

I have in the past had similar problems with Hikivision software. I assume its all to do with security.

But is there any way around it. Apart from not installing updates during the night.

Why do you want NetcamStudio.Client.exe to autostart? That’s not interesting. Netcam Studio running as a service should be configured to autostart as described in the guide. That is the program that runs motion detection etc. and record the videos.
When you want to view a recording then you start Netcam studio client or web client.

I wanted Netcam Studio X to run on boot up, because the service was not running. But things have changed because NCS finally crashed (see next posts)