iDigital V380 information/compatability


#1

Hi.
I recently bought a V380 camera in Australia, branded under iDigital. Does anyone possibly have any experience with this camera? I have being reading through other posts on this forum, plus elsewhere, but so far little from sister models seems to apply. The V380 app lists the camera’s details as:

Sys app version:
AppRTSE0_PTZ_v2.0.1.21_20180129
System kernel version:
KerRTSE0_PTZ_V2.1.0_20160902
System firmware version:
HwRTSE0_WF3_PTZ_20160902

A port scan shows the following ports open:

Port 5040 (TCP)
Port 5050 (TCP)
Port 5051 (TCP)
Port 7050 (TCP)
Port 8800 (TCP)

Trying to telnet to these ports, the majority close immediately. Port 8800 however does not. It accepts connection but does not show any output. I’ve tried various combinations of username/password, including root. None produce any response. I am wondering if the camera may be waiting for a magic string? After around 15 seconds the port closes.

I have tried getting this camera to work with webcamXP and Netcam Studio, neither successfully. From the port list, the camera obviously doesn’t support rtsp connections and I’ve had no luck with ONVIF connections either. I’m not sure if there is a reasonably generic V380 ‘brand’/model in these which I could try? I have tried the MVCMS_Lite app which comes as part of the V380 SDK on Github. This does connect and work with the camera however functionality is extremely limited and sporadic with only camera movement (somewhat) reliably available.

I’d be interested in any information anyone has available on this particularly V380 incarnation. The app for the camera shows no current firmware updates however given a few patches for sister models seem to available from the (V380) manufacturer, I am considering contacting them. Any pointers or suggestions in the mean time appreciated.

Cheers.


#2

Hi,
Port 5050 tells me that it use a multimedia format which is an encrypted format for video and audio. To work with Netcam Studio the camera must support mjpeg or rtsp. I think this camera is a Chinese one that is branded under many names. Search for v380 here in the forum and you have more information what other users have done.

-Henrik


#3

Many thanks Henrik.
I had read through all posts on here relating to V380s and tried the various options presented with no success. I just went through the posts again, retried and still, no success. The camera is not accessible via ONVIF Device Manager. It is similarly not seemingly accessible via urls of the form:

rtsp://username:password@ipnumber:port/live/ch00_1

As well as variations on the above.

The camera is not detected by IP Camera Finder. Firmware/system patches for some sister models didn’t not apply from SD card. I’d noticed these had an embedded model number however so I am not surprised. I’m not hugely tempted to try and fudge the model information in these files for fear of bricking the camera.

Are there any other feasible avenues to explore I may’ve missed in other posts?


#4

Sorry nothing I can do. You got to buy a camera that support standard behavior.
-Henrik


#5

That’s a shame as these otherwise seem quite good cameras.

I did a little more poking using Wireshark while attempting to connect to the camera using NVCMS_lite. It seems some sort of magic packet is sent to port 5050 to initiate a connection. The username and password are then both sent in clear text. It looks like there may also be some sort of connection attempt to a site ending in nvdvr.net. From there the camera seems to return a H.264 stream.

I shall try contacting the original vendor of the V380s and see if there is any sort of firmware update or patches to enable additional functionality.


#6

Try the string rtsp://ip_addr/ch00_1

Some of the latest V380 based cams need to have a patch file added to the firmware by putting it on a SD card and power on the camera. It’s explained in another thread.

/Ubbe


#7

I tried this type of hundreds of commands but failed:
rtsp://admin:passcode@192.168.x.x/live/ch00_0
VLC shows this error "VLC is unable to open the MRL ". I did change and marked “Use RTP over RTSP” but still error remains the same.

Shouldn’t I need to specify the port number? I tried but I couldn’t find one.


#8

Check that your camera use rtsp and that port 554 is open.


#9

Using WireShark I tracked camera local IP, it’s protocol wasn’t RSTP but IGMPv3.


I did an online search on WhatIsmyIp website by giving my public address. It shows(in attached SS) every port is closed except DNS however I tried to open HTTP by Router settings>port mapping but it didn’t changed the results.

Thank you so much for your reply!


#10

Furthermore, I’ve read your discussion with some other person and then I installed ONVIF Device Manager. It detected IPCAM automatically but failed to generate live stream.


#11

Command Line results for the camera:

Nmap scan report for 192.168.100.9
Host is up (0.0076s latency).
Not shown: 996 closed ports
PORT STATE SERVICE
5050/tcp open mmcc
5051/tcp open ida-agent
8800/tcp open sunwebadmin
8899/tcp open ospf-lite

I specified port 554, it showed this port as a closed port. The list of other ports is above. Can I use any other port from the above list?


#12

Sorry, but no. Port 554 is the port for rtsp. Port 5050 is the classical port for multimedia communication which is an encrypted stream with some protocol that can be propitiatory.

It´s interesting that ODM pics up the camera. There is a lot of discussions of this 380-camera and everyone have the same problem. Some have used another firmware and made it work.

-Henrik


#13

I just ran a command:

telnet 192.168.100.9 8899

it showed me a blank page which means this 8899 port is listening for camera. Can’t I use this port for video?


#14

Just to give a bit of a belated update on the iDigital branded V380 sold in Australia…

I contacted the original vendor. They confirmed my camera has the latest firmware and that the camera does not support RTSP or ONVIF. I asked about the patch floating around for the V380E. They confirmed the patch is not compatible with my camera (which i’d already found - it doesn’t even seem to try to apply) but that a similar style patch (for maintainance, not extra functionality) could be applied to my camera.

Looking at this files in the patch it seems it may be possible to try things like enabling telnet for the session without much risk of bricking the camera but i haven’t dug further at this stage.


#15

Probably not, but test. The firmware in the camera use a specific port for communicating video and audio. Now that port is 5050 with some protocol. To use another port and a known protocol you must change firmware.
The only way to find out is to test.


#16

Thank you so much for your reply.
Can you please send me the patch files?


#17

I’m going to update my firmware. Do you have the patch file? Can I upgrade firmware without SD card? Is there any tool for updating firmware by providing my own patch file?


#18

Sorry, but I no nothing about this camera. You must search in the forum here to find answers.


#19

Have a look in this earlier thread - Fentac V380 Connection

There is a patch file about 12th post down, plus a slight tweak to it later. There is some info about what and how in that post. I can’t add anything to the discoveries of others so far.


#20

@ZCed & @Henrik Thank you so much, guys. After updating firmware I accessed my camera but there is just one thing left. How can I access it from outside of my network? AFAIK 192.168.x.x is my private IP for the camera and 72.255.x.x is my public IP for my router. So, how can I access my camera from outside of my network?