MP4 files short and invalid

I am new to NCS. For the first few days, it worked great. I was able to connect it to my camera (D-Link DCS-930L) and record to .mp4 files.
Then, I stopped the NCS application and started the Windows service. The .mp4 files started getting saved with a size of (exactly) 307 bytes in size and contain no video.
I stopped the service and started the application again. Still 307-byte files.

It is only the saving to MP4 files that is broken. Everything else looks fine (live video works, no errors in the event log, I can remove the camera and add it again).

I tried uninstalling, but when I reinstalled, all my settings were still there, so I couldn’t undo any bad settings. (And still small MP4 files.)

Is there a way I can wipe settings and start again?
Any idea why running as a service seemed to break things?
Is there something else I should do to troubleshoot?

Grateful for help to a newbie.

Read this Netcam Studio is working and record files, but when I play a recording it is empty?
How to make a clean installation of Netcam Studio

Yes, that was it. I had pulled the frames per second down to 1. When I changed it to 2 fps, I got proper size mp4 files. Thank you for helping with that.