New PTZ camera - PTZ controls not working properly


I just got a new 1080p PTZ camera from Amazon -
It is setup in NCS as an Onvif camera.
If I access it through Onvif Device Manager v2.2.250, everything works properly, but if I access it through NCS 1.7, and try the pan, tilt, or zoom, it behaves as if I am holding the control down after only clicking once on it. i.e Full left, or full right, full up or down, etc.
Also behaves the same using the NSC app on an iphone.
Is there anything I can do in NCS to fix that?


Additional information:
I works the same in NCS client, NCS Web Client, NCS IOS Client. (Continuous movement after one click)

When you add the camera in the ONVIF tab you can select different modes for PTZ. Have you tested both modes?

Yes, I have tested both Continuous and Relative - same thing.

I am forwarding this to our developer.

Having same issue with this camera

PTZ works fine in HP2P IP camera ap and the app that came with the camera. But any use of PTZ in Netcam Server is all or nothing. I also have an older camera with no zoom that only works on continuous mode but acts as if it’s in relative mode. If set to relative mode that camera PTZ does nothing. I even uninstalled and redownloaded latest version.

Yes, they usually use their software in the apps that makes it run very smooth. Using ONVIF is something else where they must comply to a standard which they not always think is so important. My only recommendation here is to check if there is a new firmware for the camera that you can install.

After your response I downloaded 3 other aftermarket ONVIF viewers and PTZ works correctly in all of them. So this is NOT a valid response to the issue. It seems that YOU are the one who is not adhering to the ONVIF formats correctly

Thanks, I am forwarding this.

I just downloaded this app and so far its the best one I have tried but it’s the only one that the PTZ function does not work properly ( I have tried six different ones). Like others have said it just continually moves with one touch and it will not stop. It’s really too bad

Can you give me what camera you are using?

@Henrik just to add to this thread. I’ve a new camera added now, and the ptz, if you tap a direction, it goes all the way, no way to stop it. I’ve tried “continuous” and “relative” and it’s the same for each. However if I use Onvif Device Manager, or ANY other cctv software, the ptz works as expected. Wondering if there’s a bug in NCS maybe?

Yes it’s recognized and we need to look into why this is a problem for some cameras. What camera is it?
If you have the time, when the canera is connected go to the tab for Custom URL. What is the URL in the Address field?

1 Like

@Henrik Thank you for the quick reply.

The camera is this:

After adding as Onvif, the custom URL tab shows this: rtsp://USERNAME:PASSWORD@

and the Stream Type is RTSP_UDP

User name and password changed in the above :slight_smile:


@Henrik @Steve Will this be fixed in the next update? :slight_smile:

Many cameras use the same basic electronics so here are a couple of cameras that have the same URL for rtsp, but with different PTZ command. When adding the camera use the tab for Network Camera.
1.Aztech, WIPC402, RTSP
2.Foscam, FI8601W, RTSP
3.Foscam, FI8919W, RTSP
4.Digitus, DN-16036R2, RTSP stream 1

These cameras run rtsp over tcp so it depends if your cameras support tcp. Usually cameras work for both tcp and udp. If you check in the camera configuration there might be a setting for this, but test first. Cross fingers :slight_smile:


1 Like

If you are interested please read my last post here about adding this camera as alternativ camera models. Your camera use the same rtsp url.

1 Like

@Henrik Thanks for this. When adding via onvif I only have UDP for this camera, no TCP. Maybe this is the problem? I will try the network camera options when I have a minute and report back :+1:

@Henrik Perfect!! The first Foscam worked a treat. Great help from here as always, thank you :blush::blush:

1 Like

Excellent! Thanks for your assistance.

1 Like