Outdated SSL/TLS Version - Chrome


I have made some changes to my NetCam Studio since the Google changes noted here:

I have purchased an SSL certificate and successfully installed it in NetCam Studio.

I now have an issue with Chrome still not properly showing the embedded webcams.
When I try to navigate to the NetCam page directly I get the following message:

Your connection is not fully secure

This site uses an outdated security configuration, which may expose your information (for example, passwords, messages, or credit cards) when it is sent to this site.


If I trust the site then go back the embedded cams will load properly until I close my browser.

I’m wondering if updating NetCam Studio to a different version might solve the issue?
I also am not sure how difficult upgrading will be - I am currently running version

Thank you for any input!

I have never seen that, but I am using NCS 1.9.2.
Going from version 1.6.1 to 1.9.2 is a big step since a lot of things have changed. I am not sure if just upgrading will work properly. If you do that I would recommend to install the necessary prerequisites for version 1.9.2 to run before the update. Check the download page for software.
Alternative is to make a clean installation of NCS meaning starting all over. Here is a guide for that How to make a clean installation of Netcam Studio
Install prerequisites first is best.
Save version 1.6.1 if something goes wrong.

1 Like

Hi, just wanted to post an update.

Updating NCS software version did in fact fix my issue.

Thanks for input!

1 Like

I am having the same problem am also on 1.9.2, did you perform the clean install or just simply update?

Is the problem with a self-signed or a commercial certificate? Make sure that the certificate is stored on the correct location. Some users report that the new wizzard places the certificate in the web folder.

I bought from rapidsslonline.com, i installed and thought it was correct.
If i give you the url could you take look and see what your think?

Have you tested so it works with self-signed certificate?
You can send URL to support@netcamstudio.com

Yes, i did but mobile browsers would not load, i then switched to the purchased certificate and received the current error.
Email sent.

I also switched from 32bit to 64bit versions if that helps.

I’m thinking my problem is with the certificate type itself, i don’t have a wildcard certificate, and since i’m using a subdomain to host the stream i think i might need to switch.
Would you mind telling me what certificate you used?

I used a subdomain, no wildcard cert.

I cancelled my rapidssl single domain cert and bought a wildcard ssl, went through all that garbage and it still doesn’t work. cancelled that, trying a single subdomain ssl from godaddy next (my host) perhaps i can get some support from them and i can move on with this.

Got it figured out, thanks for your input.