This version of Netcam Studio Free is outdated, please download a newer version or enter a license key to keep using this specific version

Hi there, i’m using Netcam ver. 1.9.2, it was fine until today. For some reason it just stop launching server with this error. I though there is a new version but after i reinstalled Netcam, seems like version not changed. I tried to install on another PC, but still have the same issue. Any suggestions what happened and how i can fix this ? Thank you.

Error 10:58:56.187 ConsoleHost.StartServer Exception occured in StartServer
Exception Detail: System.SystemException: This version of Netcam Studio Free is outdated, please download a newer version or enter a license key to keep using this specific version.
в Moonware.Core.MoonwareCore…ctor(NetConfig )
в Moonware.Server.WCF.MoonwareServerWCF…ctor(NetConfig )
в e..() H 905 T 24 132,98MInformation 10:59:16.229 NetcamStudioX.SaveClientSettings Client Settings Saved H 930 T 24 100,49MB

Hi,
Thanks for info. I am on it!
-Henrik

Thank you for reply, is there any approximate time when problem will solved ? Thank you.

Same problem this morning

Same problem here - not working anymore…

Same…I’m missing being able to keep marauders at bay with this excellent software!

same issue for me too

yep, same here. Tried to do a repair install with a new download… same error.

New version in the pipeline.
-Henrik

2 Likes

I’m sorry Henrik, where is the pipeline located?

Same problem here.
It is saying;
This version of Netcam Studio Free is outdated
I’m on 1.9.2.0

Same issue here. I am on 1.9.2 as well.

Still broken 12/06/21

@Henrik Why would the system determine that the (in fact current) version (1.9.2.0) auto determine that it’s out of date, when the new version hasn’t been released yet?! Seems the devs need to get their ducks in a row before they go disabling peoples’ instances… VERY FRUSTERATING!

1 Like

If I may speak as a software engineer of 30+ years: bugs happen. My guess is that this is a very small development team.

It smells to me that a specific dateline was crossed (June 1) that caused the software to fail. Why the code would be looking for that date is beyond me; but that it my initial guess as to what happened. I hope that no one who is experiencing this is using the software in a mission critical way.

As an aside, this is exactly why so many people around the world worked so hard to ensure that there were not disasters when the century dateline (Y2K) was crossed.

1 Like

To be very frank I am the one that should be “VERY FRUSTERATING”!
-you get the software for free
-you get all the updates for free
-you get the support for free and many users of the free version don´t even bother to read the manual
-if the software is so crucial for you I would strongly recommend to buy a license and support all the efforts that we put into this instead of complaining not getting everything for free. If Netcam Studio really is mission critical 49 USD is nothing compared to cost for computers, cameras etc.
-we are very generous supporting the free version.
-actually a lot of users have bought a license for 4 sources which we very much appreciate.

When the new version will be available it can be downloaded from the website.

-Henrik

5 Likes

Agree with you 100% Henrik!

2 Likes

I’m one of those “created an account just so I could post one thing” people, so please take my words with that in mind.

Henrik, I’m sorry about all the people adding to this very stressful situation. I worked in software and I know what it’s like to have outside people tell YOU what to do with YOUR product. It’s annoying and it’s hard to stay objective.

People with unrealistic expectations will always want more, and they won’t be thankful. They’ll complain when things are good, and also when things are bad.

But I’m not one of those people. I was a happy user, preparing to buy bulk cat5 and two more cameras so I could expand my system. I was experimenting with encoding settings, gearing up to upgrade to the 4- or 8-camera plans.

Your bulletin board guidelines encourage people to criticize ideas, not people. But with this anger, you’re doing the opposite. You’re telling me that I shouldn’t depend on your product as advertised. You’re telling me I should be grateful to use your product at all. (It’s still listed on the download page right now. Any new users won’t be able to use it.) You’re yelling at me for not paying for your product.

It’s not about the customers who want to pay nothing and get everything. It’s about the customers who want to try a product so they can confidently pay for it.

With this sudden bug and this outburst of anger, you’ve taken all of my confidence away. If you react like this AND you can shut down my software remotely, how can I trust you at all?

3 Likes

I also created my account just now to state that Zenknee is absolutely correct because this happened to be my case exactly.

I restarted my machine (and studio service) because I was switching a cam from Wi-Fi to ethernet, and I get this error. I assumed that buying a license would remedy the situation, and was going to do so, but I thought I should check here first to see if it was a known issue.

Then I saw the dev throwing a temper tantrum in the support forum.

Yeah… I’ll find another solution.

1 Like

This is a temporary solution that may work. It did restore my test configuration…

    1. Close NetCam serverx
    1. Change the system date to one month prior.
    1. Restart NetCam
    1. Change the date back to today.

As long as you don’t close the application, it appears to operate…

Again, this is not a fix… just a temporary workaround that appears to work on my test bed…

3 Likes