Universal Source Filter



until this morning i used Webcam7 Pro and 7 ip cams conncted with universal source filter (v 4.5). Now I see a black bar in the middle of the captured pictures with red letters “this version of the filter is outdated please download a newer version”. So I did. After installing filter 4.6 the black bar appears again. I uninstalled the filter and webcam 7, restarted my computer an installed Webcam 7 pro and universal source filter 4.6 again. After connecting all cameras the black bar was still there.

Do you have a solution?

best regards



Hi Rainer,
I started my webcam7 pro and also got this banner even with version 4.6 instilled so this I have to froward to @Steve to look into.


Hi Henrik,

thanks for the information. Unfortunately I have to deactivate the upload of the pictures until I receive your answer.



I have prepared and uploaded a version 5.0.1:


It also includes the latest changes / improvements to RTSP sources from Netcam Studio as well as the latest version of ffmpeg.

Please give it a try and confirm that everything is ok. I didn’t have chance to do much testing.


Hello Steve,

using the version 5.0.1 Edimax IC 7112 works well without banner. But I’m sorry, the other 4 Foscams C1 cannot be connected to webcam7 pro (white picture). Webcam 7 crashes when I try to change settings or close the connection. Webcam7 can only be closed with task manager.



Take up the configuration of the filter for the camera that works. At the botton left you have a checkbox that allows the filter to bu used with several cameras/instances. Make sure that is enabled/checked. I tested with 3 cams and it worked.


multiple instances support is activated at all cameras using the filter.



Let´s say that we have had better days. I had 2 cams with filter and a usb cam, sorry. You are correct, it is not working correct. Sometimes it hangs and sometimes not. When Exit it leaves instances running. @Steve need to do some further testing.
Sorry and thanks,


perhaps it can help:

instance 1 with filter foscam doesn’t work
instance 2 with filter foscam doesn’t work
Instance 3 with filter Edimax works well
instance 4 with filter foscam doesn’t work
cam5 with template works well
instance 6 with filter foscam doesn’t work
cam7 USB cam works well
cam8 with template works well
There is no possibility to change settings of the foscams. Settings of the cameras (source configuration of the capture filters) are correct, resolution is shown with 0x0
if you need more information you can contact me til 23.00 (my time germany)



Will have a closer look at this and perform my own tests right now.


Ok, found the problem it’s apparently not bundled with the expected version of ffmpeg and causes very high cpu + freezing on some models (and some do work) so it looks like your problem.

Looking forward to fix and prepare another package.


More a workaround than a fix for the time being:

I had to rollback to the previous ffmpeg versions for reasons that I don’t get at the moment. The filter uses the exact same code than Netcam Studio (which works perfectly fine with the latest ffmpeg) but running multiple instances of this code into the directshow filter seems to freeze and hang at some stage.

When going back to previous ffmpeg version it seems ok so it’s what I did in this 5.0.2 until I understand what is wrong and can move to the new ffmpeg (same that we use in Netcam Studio).


with version 5.0.2 2 (two) of 5 Foscams and the others are connected. workload cpu by about 34 % (only webcam7). So far so good. The other cams can be connected to my system not until at 7.00 CET in the morning (external power supply by timer). So I will tell you the result later

with best regards


the result this morning:

all banners are gone. cam 3 (edimax with filter) cannot be connected. webcam 7 can only be stopped with taskmanager. Unfortunately the workaround didn’t remove the mistake completely.



here I have all my rtsp cameras connected and were running all night.

this morning i was able to stop / exit webcam 7 and restart it so right now i’m not able to replicate the issue.

please provide details about the edimax url / mode you use and step so that you end up with webcam 7 that cannot be stopped.


However i have figured out the problem with newer ffmpeg build and where it comes from so it’s potentially linked and will anyway soon provide an update.


if I send you a screenshot of the filter settings, everyone can see acces data and IP adress. I do not like this. Can I send you screenshots with email for your personal use? I think the filtersettings of 3 cams for example are enough.
On my older “emergency pc” webcam7 is installed too with the same settings. Using this older PC with filter 4.5 there are no problems except the banners



Hi Rainer,
Hang in there. Steve have found several issues and figured out the problems. He will soon come with a regular update. I suggest we wait for that update and after we have installed it we will see how it goes. Do not post any sensitive information here. When or if that will be necessary we send you a PM which is a closed channel where we can exchange details.


Pushed a 5.0.3 here:

Hopefully this is the one, now seems to work and not to freeze with latest ffmpeg and also fixes a problem where DXVA2 was always (tried to be) used no matter of the selection in the filter.

Still requires more testing but I suppose it should be ok now.


Sorry, no better results.

At the first time I installed version 5.0.3 in the source filter window version 5.0.2 was shown. I deleted the filter by software an then deleted files in c\appdata\moonware and c:\programm files x86\moonware. After installing 5.0.3 again, in the source filter window v5.0.2 appears again. Wich filter is running now?

Still no connection to cam3 edimax. to delete this cam is not possible. the same for trying to edit filtersettings. Webcam7 cannot be closed, only by taskmanager. I think webcam 7 tries to connect to cam3 without success. This may be the reason for all mistakes. Once again, on my old “emergency pc” (same OS windows 10 prof) there are no mistakes with filter 4.5 (except the banner). I don’t think that there are any differences in the settings. I compared ist several times . Webcam7 is running only at one pc at the same time, so that the rtsp stream is not to share.