Universal Source Filter


I have an Edmiax and tested NCS with rtsp and mjpeg and it do not connect. I works with h264.sdp


I think some Foscam users recently had issues in NCS with MJPEG over RTSP as well so i’m investigating this.

this rtsp:// xxx.xxx.xxx./ipcam_h264.sdp works for you Henrik ?


Yes, that works for Henrik (I need 20 characters).


ok, found why mjpeg is disabled (there was really a discarding check if codec the codec was jpeg or mjpeg in some part of the rtsp decoder).

That was to allow playing local movie files, some do have the cover or a sample embeded and to prevent this from being used instead of the “real” movie. I’ve disabled the mjpeg check and now it works fine :slight_smile:

building a new filter… good news is that it will automatically fix the next ncs release as it’s sharing this code with the filter.


Grrrr a lot of extra work! :smile: and soon we have 20 characters!


Ok, here is 5.0.4:

Really hope this time everything is fine (i’m anyway off for long weekend as of tomorrow morning :))


In will test it tomorrow. The result I post at tuesday and I wish you a nice long weekend.


Well I have been able to test it with MJPEG over RTSP. Now that we knew that this was the problem on your end with the information you have provided, I really hope it was the only remaining issue :slight_smile:


the filter can not be installed. starting webcam 7 there is no filter


I’ve installed it on my system before uploading to ensure it’s fine.

Just tried again right now (uninstall / reintall) and went ok.

I’m reuploading the package just to be sure.

Are you sure that webcam 7 (or anything using the filter) was not running when you tried to install it?


if needed (to have detail of install issue) run from a command line:
musf-x86.exe /l*v c:\temp\install.log and send us the install.log file

But the installer itself seems ok. Henrik did you gave it a try ?

Also if you patched the dll of ffmpeg manually they may remain in the folder. After uninstalling, ensure that the folder is clean.

listed #54


No, I am tired.and to get 20 characters.


Hi Henrik,

after removing Webcam7 and filters by software an deleting all folders and files in appdata und programmx86 webcam7 now works well. Edimax is running with h264 and mjpeg. I prefer a lower resolution so that you can read the optional header text. I received your last mail at 00.37 this morning but not the PM, but now it doesn’t matter anything. Many thanks for helping me, I don’t think about the reasons anymore.

best regards


Excellent! Finally, some good news :slight_smile: Yes, sometimes it can be good to remove everything and do a fresh start. I will do the same on my side. Thanks also for your efforts in this to make it work! More questions you know where to find us.
I just installed it and and it works fine for me too. I can really see an improvement in performance and a much better response of the software. These improvements implemented in NCS will be very interesting to follow.