V 1.9.5.0 keeps freezing

Just upgraded to 1.9.5.0 and it now stops working after ~20 minutes.
If I restart the service then it runs for about another 20 minutes then stops again.
Previously ran OK for Weeks & Weeks with no issue so it’s got to be this version
ANyone got any suggestions?

Hi,
Very annoying. Go to Windows event viewer and applications. Look for red error icon and Netcam Studio. What is the reason for the stop?
What version did you upgrade from? In version 195 it was quite a few changes that might cause this. You can do a clean installation. Read more about that in the section for guides & tutorials How to make a clean installation of Netcam Studio
-Henrik

Is there anyway I can download reinstall 1.9.4.0 first?. Then I can check my findings.

I’ve looked in bother Apps & System event viewer, there’s nothing obvious that I can see, and I’ve checked about the time the remote web viewer stopped

No download of previous versions, but why can’t you check findings in 195?

Having the same issue here.

Just tried a restart of Service which normally starts everything up again for a while but not this time, in YOUR event log I get
WCF request failed RefreshCachedStatus
Exception Detail: System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at http://192.168.1.11:8100/Soap/ that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. —> System.Net.WebException: Unable to connect to the remote server —> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 192.168.1.11:8100
at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
— End of inner exception stack trace —
at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStreamAsyncResult.CompleteGetRequestStream(IAsyncResult result)
— End of inner exception stack trace —
at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
at System.ServiceModel.Channels.ServiceChannelProxy.TaskCreator.<>c__DisplayClass7_01.<CreateGenericTask>b__0(IAsyncResult asyncResult) at System.Threading.Tasks.TaskFactory1.FromAsyncCoreLogic(IAsyncResult iar, Func2 endFunction, Action1 endAction, Task`1 promise, Boolean requiresSynchronization)
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Moonware.Controller.ClientController.d__102.MoveNext()
There’s nothing I can find in either of the usual windows logs however.
Today the only way t get it up & running again is to restart the PC, that works, but for how long?

It´s been two Windows updates during the last hours for net framework. My system also crashed. Uninstall these updates, restart computer and go to Windows Update and it will install again.

The only upgrade my NetCam Studio PC has installed over the last week is " KB4023057: Update for Windows 10 Update Service components", and from what I can see that shouldn’t interfere with you program anyway.
Ironically, after two PC restarts today Netcam seems to be running OK at present, it’s been up for ~5 hours now with no problems, so I will keep you advised

It ran until 18:03 03/Oct/21 then froze again

erratic, runs for anything from 5 minutes to 6 hours then stops. Nothing obvious in the windows logs to suggest an issue with windows.
Tempted to revert to YAWCAM, nowhere as good, but it was reliable

Have completely uninstalled, using IOBIT uninstaller, then manually gone through Program Files & Program Data and removed ANYTHING to do with Moonware.
Also gone through Registry & removed anything.
Reinstalled from new download, no improvement, if anything it’s worse as it only runs for about 15 minutes now then freezes

As mentioned earlier go to Windows Event Viewer and look for red icon error and Netcam Studio or .NET

It is a problem with a bad Windows update since it has been working before. Go back and uninstall the windows updates that was installed just before the problems started. Install NCS again and control that it works. Go to Windows update and do an update again. If that do not help reinstall windows which today is quite easy since it is already on the HD.
-Henrik

Is there any anti-virus software running on the machine? I’m on 1.9.5 on Windows 10 Pro, running Avast anti-virus. Never had an issue and all Windows updates auto install and the machine restarts as and when needed. However last week the service started to stop randomly. I disabled the AV and it ran perfect again. This was since an update to the AV software. Back to Windows Defender and it’s running sweet again. Just a thought, disable any AV software (temporarily) and see if there is an improvement. Fixed my issue :+1:

1 Like

Another tip. I installed NCS 195 on a computer with an older Windows. I updated Windows 10 Pro to latest 21H1 and NCS randomly stopped. In Windows Event Viewer I discoveted an old version of Visual C++ caused the crash. Updated Visual C++ from NCS download page and all systems running again :+1:

can you supply a link, I’ve looked on your site and can’t find a C++ download

I admit it´s a little bit awkward, but go to Netcam Studio - Network Camera Surveillance Software . NCS will start to download, but on the page you will have links to the pre-requisites.

Thanks.
Actually based on your suggestion I looked in ControlPanel.Add/Remove Programs…Windows updates and found one SOMETHING LIKE Windows C++ Update 2018-2021 which I removed.
HAving done that I restarted NCS and so far (>12 hrs now) it runs again

1 Like

Downgrade to 1.9.2, it is more stable version on very up to date Windows 10 Pro, too.
I had this issue, but no more. I got back to 1.9.2. (1.9.5 have other not so common issues as well)
Downgrading of OS is not a long-term solution imho.
Henrik proposed to me some clean install and other experiments, but honestly I have no time and effort for testing a retail software :slight_smile:

I had problems as well, however a real uninstall, use IOBIT uninstaller, then go through registry and completely delete any Moonware AND Netcam hives. Remove any Moonware folders and Netcam Folders on hard disk, then install 1.9.5 does seem to work. Since reinstall & reconfigue I’ve now been running for 6+ days with no issues to date.
It’s a pain reconfiguring from new again, but it does seem to sort out problems.

Thanks, that did the trick for me !
Never got problems with NCS untill i did buy a new extra camera.
Kept freezing and freezing so i did send the camera back.
Few days ago i did buy a Imou Cruiser camera : same problems with freezing screens.
After updating the C++ files it didnt happen once :slight_smile:

1 Like