V380 stream url

Hello,

I am having a problem with my camera ip v380 smart net camera.

I can get the image on the v380 software on my phone as well as on the windows version.

but nothing works when I try with rtsp address on vlc or other.

Do you have to do a special manipulation?

Thank you !! (Sorry for my english)

Have you tried the windows app here (http://www.av380.cn/Gjh2.htm) or is it the same version…?

Download this file (ceshi.ini)(https://1drv.ms/u/s!AsiWKsjhQ2jegp4cGv3341A9Jlv5kA?e=wHZJCf) and put it on a empty sd card or root of sd card and turn off camera then put sd card in camera,now turn on camera and wait ,you should here something seid in chinese between its say “System Starting” and “connecting to wifi”, wait for about 5 minutes then turn off camera take out sd card and then turn it back on and use this url to connect to it Via Netcam Studio or Ispy "rtsp://user:pass@IPADDRESS/live/ch00_1” its worked first time for me. User Pass is the user and password you set in the V380 app for the camera. Example url… “rtsp://admin:hello@192.168.1.54/live/ch00_1” if the url sill don’t work try changing the channel to 0 so at the end of the url “ch00_0”.you can try different numbers at the end.

1 Like

Hello,

thanks a lot for your help. I followed your advice and did all the steps in order, I heard the voice in Chinese but it still does not work when I start the stream on VLC.

When I go to this address http://192.168.1.16:8899/ I get that :

rtsp://admin:WhateverThePaswordForCamIs@192.168.1.16/live/ch00_1

You don’t use 8899,only that url,it should work,It work with another IPcamera I just bought too.

@Spanner
Danke für den Tip mit der Datei ceshi.ini
Hat super funktioniert

Thanks for the tip with the file ceshi.ini
It worked great

For people with firmware:
Software version: AppV380E11_EXIOPTZ_ETH_V2.5.4.0_20180611
Firmware version: HwV380E11_WF3_EXIOPTZ_ETH_20160217

After update it will be:
Software version: AppV380E11_EXIOPTZ_ETH_V2.5.9.5_20180611
Firmware version: HwV380E11_WF3_EXIOPTZ_ETH_20160217

The update file from links above didn’t work for me, so i contacted the support team at v380technical@gmail.com they provided me with an update file:
AK3918E-V200_V.2.5.9.5 .zip

extract and copy files to root of the memory card, insert the card in the camera, you will hear update complete after 2-3 minutes, remove the memory card and create the “ceshi.ini” file as mentioned above in this thread.

After that i can see the rtsp stream, the problem is i can see it without even entering the ID and Password :laughing:
And the other problem is i can only see video, no audio.

Now i’m wondering if there is any trick to update the time and date of the camera automatically after starting the camera, something like the ceshi.ini file.

2 Likes

Thank you for this post. This did the trick for me as well.
Firmware version:
HwV380E12_WF3_PCARD_V50_20180628
In installed the ceshi.ini in the root dir of an SD card, switched off the camera, put the sd card in the camera and switched it on again. My camera gives voice messages to tell what it is doing. Some of the messages where suddenly followed by chinese messages. After booting, I let it on for a little while (5 min) (maybe it had to download new firmware or so, although I don’t think it did), and then switched it of again and removed the sd card. Then I rebooted. The chinese messages were gone now, just plain english, as before. A port scan (using masscan on linux) revealed that now the following ports are available: 8899, 554 and 8000. Port 554 is rtsp and I managed to get it working in VLC media player (open network stream, using the url that you mentioned in your post.

Hi all!
Thank you so much for your contributions. I managed to see the video through the /live/ch00_1 url. Ports 8899, 554 and 8800 are open but, there’s no audio!.. I’ve tried everything, any clue about how to get the audio too?
Also, port 23 is closed… do you know how to open it for telnet and maybe get more info?

Any help is much appreciated.

Thanks!

Good morning, since I updated the versions of the internal software of the cameras, the quality of the video was very low, did someone happen to it and could I solve it?
the image has a lot of noise, and the night vision impossible to walk. nothing is seen

Me pasa lo mismo el video cuando las compré era muy bueno y ahora es terrible la calidad voy a subir una foto

UPDATE AS OF OCT 23, 2020 from V380 Technical team email:

Download this file (ceshi.ini)(from v380 support email 1 - Google Drive) and put it on the root of sd card (with at least 1MB storage space left) and not inside a folder then turn off the ip camera then put the sd card in camera, now turn on camera and wait, you should here something said in Chinese between its say “System Starting” and “connecting to wifi”, wait for about 5 minutes then turn off camera, take out the sd card (if want to use the SD card on your v380 ip cam you need to delete the ceshi.ini before inserting it) and then turn it back on and use this url to connect to it Via Netcam Studio, NVR or Ispy “rtsp:// user:pass@IPADDRESS:554/live/ch00_1” it worked first time for me. User Pass is the user and password you set in the V380 app for the camera. Example url for HD stream… “rtsp://username:password@192.168.1.88:554/live/ch00_1” or the SD stream “rtsp://username:password@192.168.1.88:554/live/ch00_0”.

1 Like

Hi
I have an A9 Mini Camara with V380 app. Will this method work with my camera?
A9 Mini Camera
HwV380E12_WF3_AK_MINI_20180628

Hi, I have the same camera as Muzoffru but it doesn’t work for me.
I hope there is another solution.

Hello!
I have Camera V380
System app Version: V380E11_V2.6.6.6_20210410
System kernel Version: ??? [Can’t find out]
System firmware Version: HwV380E11_WF6_AKQ8_MS32006_20180628

I was able to connect this v380 with RTSP both FFMPEG & VLC & video and now works OK with my survelance Station
However PTZ is not working.
Could you please let me know how to configure PTZ for v380 ?
For reference:
I using a homemade ceshi.ini of this forum
with content:
[CONST_PARAM]
rtsp=1
rtspaudio=1
audio=1
audiorec=1
audiorecord=1
micrec=1
mic=1
microcord=1
telnet=1
ssh=1
onvif=1
web=1
webinterface=1
webif=1
http=1
I tried to open all ports in this camera, but
has TCP only ports open: 554, 8899, 8800 & 9800
But ONVIF Device Manager v2.2.250 no see this camera!
[ PTZ works with Android App v380S only ]
It may be necessary to change the firmware version.
Can you help me with this?
Sincerely, John

hola amaigo que tal.
tengo una camara con la sigueinte version AppV380E2_ptz_v2.5.0.520160321.
sabes con que la puedo actualizar¿
no funciona rtsp.

Try to email the support. v380technical@gmail.com

lo hice pero no funciona rtsp ni onvif. antes de la actulizacion si servia rtsp

V380 cameras should come up in the device list in ONVIF device manager windows application. But the only info you can see are IP number and Country: China. If that doesn’t work it is strange.

Have you configured the camera using a V380 app in iPhone or Android phone, so that it has a IP number and connection to your WiFi?